Bug 13672 - Disk Druid won't allow clicking "Next" without swap partition
Disk Druid won't allow clicking "Next" without swap partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-10 18:29 EDT by Joshua Buysse
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-10 19:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Buysse 2000-07-10 18:29:59 EDT
Starting installer in expert mode, selected custom install, disk druid for 
partitioning.  Removed all partitions on the disk, and started adding them 
back in.  I've got separate partitions for /, /boot, /var, /usr, /tmp, 
and /nfs/brute/d1 (local convention for automounter).  The installer seems 
to think I don't have a valid setup for installation.  

Partition sizes: 
/ 500MB
/boot 50MB
/usr 2GB
/var 1GB
/tmp 2GB
/nfs/brute/d1 (rest of disk, about 23GB)
Comment 1 Joshua Buysse 2000-07-10 18:39:18 EDT
Got it -- it wants a swap partition before it continues.  Since I can see other 
situations where swap won't be necessary, and since the machine has 512MB of 
ram (more than enough to install without swap, I assume), I'm calling this a 
bug still.
Comment 2 Milan Kerslager 2000-07-10 19:29:43 EDT
Yes, there was a limit for passing without swap. A math or logic for the 
decision seems to be broken.
Comment 3 Milan Kerslager 2000-07-10 19:34:44 EDT
Damn, my mouse is so fast....

As I wrote to testers-list@redhat.com it seems to be more intuitive to 
leave 'Next' button active and generate an error message when user click 
to 'Next' without filling all the needed stuff. This allow to specify WHAT is 
missing and will save time to hotline and to beginners.
Comment 4 Brock Organ 2000-07-12 12:13:33 EDT
you should be able to install without the swap requirement using expert TUI
(text) mode ... The GUI (both expert and non-expert) installs will still require
a swap partition ... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.