Bug 136723 - Low limit for number of PCI buses seen through an mptable
Low limit for number of PCI buses seen through an mptable
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 17:25 EDT by Manpreet Singh
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 12:56:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manpreet Singh 2004-10-21 17:25:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20020903

Description of problem:
The number of PCI busses usable through an mptable, defined in
MP_MAX_BUSSES is 32 (file include/asm-x86_64/mpsspec.h).

When you boot a system with more  than 32 busses or with PCI bus
numbers (passed via the mptable) going above 32, the IRQ assignment
goes wrong causing several IOAPIC vectors to be assigned to IRQ0
(erroneously). This doesn't allow many devices to function properly.

This value above should be set to a value of 257 or more.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1

How reproducible:
Always

Steps to Reproduce:
1. Boot a system with more than 32 PCI busses or bus numbers in the
mptable going above 32. (boot with this kernel).
2.
3.
    

Actual Results:  SCSI drivers failed to detect the drives.

Expected Results:  SCSI drives drives should have been visible and the
kernel should have booted to a SCSI partition as a root filesystem.

Additional info:

Just need to set MAX_MP_BUSSES (in include/asm-x86_64/mpsspec.h, line
160) to 257 or more (like in 2.4.21 or later kernels or in 2.6.9)
instead of the current value of 32 (which remains so until 2.6.8).
Comment 1 Dave Jones 2004-10-26 23:34:49 EDT
this has been changed for beta2 (due to a rebase to 2.6.9)
Comment 2 Jay Turner 2005-01-13 12:56:48 EST
Closing out.  Please reopen if the problem is still present with recent code.

Note You need to log in before you can comment on or make changes to this bug.