This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 136728 - upgrade fails -- requires /usr/bin/update-gtk-immodules
upgrade fails -- requires /usr/bin/update-gtk-immodules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-21 18:26 EDT by Dave Jones
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 01:50:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2004-10-21 18:26:02 EDT
Description of problem:
todays up2date of gtk2 fails with ..

Unresolvable chain of dependencies:
gnome-utils  2.8.0-5                     requires
/usr/bin/update-gtk-immodules

I guess this went away in the newest gtk2, and gnome-utils needs
to be changed somehow ?
Comment 1 Marco Pesenti Gritti 2004-10-22 05:10:23 EDT
This is weird. gtk2-2.4.13-2 has /usr/bin/update-gtk-immodules and
updating with yum works fine here.
Comment 2 Marco Pesenti Gritti 2004-10-27 09:17:48 EDT
What version of gtk was you trying to update to?

Reassigning to gtk because I think /usr/bin/update-gtk-immodules is
still supposed to be there (and is still there as far as I can tell).
Comment 3 Warren Togami 2004-10-29 08:42:58 EDT
alex mentioned that this may be a multilib issue of needing
/usr/bin/update-gtk-immodules-64 or something.  If that doesn't work,
then I suspect this is an upgrade ordering issue resulting from a
dependency loop confusion?
Comment 4 Marco Pesenti Gritti 2004-10-29 09:07:49 EDT
It may also be something like this if for some reason you had fc2
repositories in the configuration.

http://www.redhat.com/archives/fedora-test-list/2004-October/msg01256.html
Comment 5 Matthias Clasen 2004-10-29 09:11:02 EDT
As marco said, /usr/bin/update-gtk-immodules *is* in all recent fc3
gtk2 packages. We really need to know which n-v-r the reporter
upgraded to.
Comment 6 Dave Jones 2004-11-25 01:50:07 EST
this bug 'went away' since I last posted here.
no idea what happened, but its no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.