Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1367421

Summary: Cannot assign subscription due to corrupt subscription list
Product: Red Hat Satellite Reporter: Sebastian Hetze <shetze>
Component: Subscription ManagementAssignee: Eric Helms <ehelms>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.2.0CC: bbuckingham
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-17 01:01:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Screenshot showing the corrupt subscription list
none
Setup script for Sat6.2 installation to reproduce the error. none

Description Sebastian Hetze 2016-08-16 11:36:56 UTC
Created attachment 1191222 [details]
Screenshot showing the corrupt subscription list

Description of problem:
It is not possible to assign subscriptions for some custom products to an activation key.

The list of subcriptions is corrupted.

Some products are missing in the list of assignable subscriptions. Instead, some subsciptions appear named "null".
See attached screenshot.


Version-Release number of selected component (if applicable):
yum info foreman
Version     : 1.11.0.49
Release     : 1.el7sat

How reproducible:
Reproducible with attached sat62-setup script.

Steps to Reproduce:
1. Install RHEL-7, prepare external IPA instance
2. customize sat62-setup script for your environment
3. run the script

Actual results:
Script fails with error:
Could not add subscription to activation key:
  Couldn't find Katello::Pool with 'id'=

Expected results:
creation of activation keys must succeed for all created custom products.

Additional info:
A 'foreman-rake katello:reindex' seems to fix the problem.

Comment 1 Sebastian Hetze 2016-08-16 11:38:36 UTC
Created attachment 1191223 [details]
Setup script for Sat6.2 installation to reproduce the error.

Comment 2 Brad Buckingham 2016-08-17 01:01:01 UTC

*** This bug has been marked as a duplicate of bug 1362194 ***