Bug 1367459 - vgsplit attempt of external origin volume fail with "Internal error: Referenced LV not listed in VG"
Summary: vgsplit attempt of external origin volume fail with "Internal error: Referenc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Heinz Mauelshagen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-16 13:03 UTC by Roman Bednář
Modified: 2016-11-04 04:17 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.164-3.el7
Doc Type: No Doc Update
Doc Text:
Intra-release bug, no documentation needed.
Clone Of:
Environment:
Last Closed: 2016-11-04 04:17:50 UTC
Target Upstream Version:
heinzm: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Roman Bednář 2016-08-16 13:03:27 UTC
This is a regression of BZ #1358961

Tested with:
3.10.0-489.el7.x86_64

lvm2-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
lvm2-libs-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
lvm2-cluster-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
device-mapper-1.02.133-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
device-mapper-libs-1.02.133-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
device-mapper-event-1.02.133-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
device-mapper-event-libs-1.02.133-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016
cmirror-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016


========================================

# lvs
  LV        VG            Attr       LSize   Pool Origin    Data%  Meta%  Move Log Cpy%Sync Convert
  root      rhel_host-011 -wi-ao----   6.67g                                                       
  swap      rhel_host-011 -wi-ao---- 820.00m                                                       
  EXT       seven         ori-------   1.00g                                                       
  extorigin seven         Vwi---tz--   1.00g pool EXT                                              
  pool      seven         twi---tz-- 100.00m                                                       
  snap1     seven         Vwi---tz-k   1.00g pool extorigin                                        
  snap2     seven         Vwi---tz-k   1.00g pool extorigin                                        
  snap3     seven         Vwi---tz-k   1.00g pool extorigin                                        

# vgsplit -n EXT seven ten
  Internal error: Referenced LV EXT not listed in VG ten.
  Internal error: Referenced PV /dev/sdf1 not listed in VG ten.

# vgs
  VG            #PV #LV #SN Attr   VSize   VFree  
  rhel_host-011   1   2   0 wz--n-   7.51g  40.00m
  seven           7   6   0 wz--n- 279.95g 278.84g
  ten             1   1   0 wzx-n-  39.99g  38.99g

Comment 3 Heinz Mauelshagen 2016-08-16 17:37:53 UTC
Not reproducing this here, neither on upstream 2.02.164, nor on RHEL7.3.
Is this a fresh setup creating the origin and the snapshots and then
vgsplit immediately fails (which I tried as a reproducer)?

[root@work bin]# lvs -o+devices
  LV    VG          Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert Devices         
  root  fedora_vm20 -wi-ao----  45.63g                                                     /dev/vda2(992)  
  swap  fedora_vm20 -wi-ao----   3.88g                                                     /dev/vda2(0)    
  EXT   seven       ori-------  64.00m                                                     /dev/sdb(263168)
  pool  seven       twi---tz-- 512.00m                                                     pool_tdata(0)   
  snap1 seven       Vwi---tz--  64.00m pool EXT                                                            
  snap2 seven       Vwi---tz--  64.00m pool EXT                                                            
  snap3 seven       Vwi---tz--  64.00m pool EXT                                                            
[root@work bin]# vgsplit -n EXT seven ten
  Can't split pool data and metadata pool between two Volume Groups.

Comment 5 Heinz Mauelshagen 2016-08-16 21:35:46 UTC
Fixed test as of comment #3 to actually allocate the external origin on different PV from the pool LVs and that leads to the initially reported:

[root@work ~]# vgsplit -n EXT seven ten
  Internal error: Referenced LV EXT not listed in VG ten.
  Internal error: Referenced PV /dev/sdb not listed in VG ten.

Comment 6 Heinz Mauelshagen 2016-08-16 21:58:50 UTC
Upstream commit c0a0eedf2e572b99e40384e68e3d5f8fba6f0ae5

Comment 8 Corey Marthaler 2016-08-26 22:41:45 UTC
Fix verified (once again) in the latest rpms.


lvm2-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
lvm2-libs-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016
lvm2-cluster-2.02.164-2.el7    BUILT: Tue Aug 16 05:43:50 CDT 2016

[root@host-127 ~]# lvs -a -o +devices
  LV              VG    Attr       LSize   Pool Origin    Devices
  EXT             seven ori-------   1.00g                /dev/sde1(0)
  extorigin       seven Vwi---tz--   1.00g pool EXT
  [lvol0_pmspare] seven ewi-------   4.00m                /dev/sdb1(0)
  pool            seven twi---tz-- 100.00m                pool_tdata(0)
  [pool_tdata]    seven Twi------- 100.00m                /dev/sdb1(1)
  [pool_tmeta]    seven ewi-------   4.00m                /dev/sdb1(26)
  snap1           seven Vwi---tz-k   1.00g pool extorigin
  snap2           seven Vwi---tz-k   1.00g pool extorigin
  snap3           seven Vwi---tz-k   1.00g pool extorigin

[root@host-127 ~]# vgsplit -n EXT seven ten
  Internal error: Referenced LV EXT not listed in VG ten.
  Internal error: Referenced PV /dev/sde1 not listed in VG ten.





lvm2-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
lvm2-libs-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016
lvm2-cluster-2.02.164-3.el7    BUILT: Wed Aug 24 05:20:41 CDT 2016

[root@host-117 ~]# lvs -a -o +devices
  LV              VG    Attr       LSize   Pool Origin    Devices
  EXT             seven ori-------   1.00g                /dev/sda1(0)
  extorigin       seven Vwi---tz--   1.00g pool EXT
  [lvol0_pmspare] seven ewi-------   4.00m                /dev/sdf1(0)
  pool            seven twi---tz-- 100.00m                pool_tdata(0)
  [pool_tdata]    seven Twi------- 100.00m                /dev/sdf1(1)
  [pool_tmeta]    seven ewi-------   4.00m                /dev/sdf1(26)
  snap1           seven Vwi---tz-k   1.00g pool extorigin
  snap2           seven Vwi---tz-k   1.00g pool extorigin
  snap3           seven Vwi---tz-k   1.00g pool extorigin

[root@host-117 ~]# vgsplit -n EXT seven ten
  Can't split external origin EXT and pool pool between two Volume Groups.

Comment 10 errata-xmlrpc 2016-11-04 04:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.