Bug 1367474 - Kernel modules for fbtft are missing
Summary: Kernel modules for fbtft are missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2016-08-16 13:51 UTC by Andreas Reschke
Modified: 2016-11-23 20:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-23 20:57:22 UTC


Attachments (Terms of Use)

Description Andreas Reschke 2016-08-16 13:51:37 UTC
Description of problem:
No display driver for Fedora 24 on Odroid XU4 with cloudshell inc. 2.2“ TFT LCD with a 320×240 resolution

Version-Release number of selected component (if applicable):
Fedora 24 and newer

How reproducible:
Install Fedora on Odroid XU4, connect it with (1) and load following modules:
spi-s3c64xx, fbtft_device, gpio-ir-recv, gpioplug-ir-recv and configure the display (2)

Steps to Reproduce:
1.
2.
3.

Actual results:
Modules
spi-s3c64xx -> found
fbtft_device -> not found
gpio-ir-recv -> found
gpioplug-ir-recv -> not found

Expected results:
Reboot the board with HDMI cable disconnected and you should see already information going to the 2.2” LCD. 

Active the required driver as a module.

Additional info:
Cloudshell
1. http://odroid.com/dokuwiki/doku.php?id=en:xu4_cloudshell
Configure the display
2. http://odroid.com/dokuwiki/doku.php?id=en:xu4_cloudshell_lcd_config
Linux Framebuffer drivers for small TFT LCD display modules
2015-01-19: The FBTFT drivers are now in the Linux kernel staging tree
3. https://github.com/notro/fbtft

Comment 1 Laura Abbott 2016-09-23 19:13:00 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.
 
Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 25, and are still experiencing this issue, please change the version to Fedora 25.
 
If you experience different issues, please open a new bug report for those.

Comment 2 Andreas Reschke 2016-09-28 09:19:35 UTC
(In reply to Laura Abbott from comment #1)
> *********** MASS BUG UPDATE **************
>  
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 24 kernel bugs.
>  
> Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
>  
> If you have moved on to Fedora 25, and are still experiencing this issue,
> please change the version to Fedora 25.
>  
> If you experience different issues, please open a new bug report for those.

Same with kernel 4.7.4-200.fc24.armv7hl. Kernel Module "fbtft_device" isn't part of actual Fedora Kernel. 
Installed:
kernel-4.7.4-200.fc24.armv7hl                                             
kernel-core-4.7.4-200.fc24.armv7hl 
kernel-modules-4.7.4-200.fc24.armv7hl
kernel-modules-extra-4.7.4-200.fc24.armv7hl

Comment 3 Josh Boyer 2016-09-28 11:20:29 UTC
Paul, is the Odroid XU4 something we've looked at?  Any comments on whether we should enable these modules?

Comment 4 Andreas Reschke 2016-09-28 12:08:27 UTC
(In reply to Josh Boyer from comment #3)
> Paul, is the Odroid XU4 something we've looked at?  Any comments on whether
> we should enable these modules?

Hint 1: till Fedora 22 the were addional RPM like kmod-staging (/lib/modules/{kernel-version}.fcXX.x86_64/kernel/drivers/staging/...)
Hint 2: 2015-01-19: The FBTFT drivers are now in the Linux kernel staging tree

Comment 5 Josh Boyer 2016-09-28 12:16:33 UTC
(In reply to Andreas Reschke from comment #4)
> (In reply to Josh Boyer from comment #3)
> > Paul, is the Odroid XU4 something we've looked at?  Any comments on whether
> > we should enable these modules?
> 
> Hint 1: till Fedora 22 the were addional RPM like kmod-staging
> (/lib/modules/{kernel-version}.fcXX.x86_64/kernel/drivers/staging/...)

Those aren't provided by Fedora.

> Hint 2: 2015-01-19: The FBTFT drivers are now in the Linux kernel staging
> tree

Fedora doesn't enable staging drivers by default.  They need someone willing to deal with bug reports and issues assigned to them before they can be enabled.

Comment 6 Peter Robinson 2016-11-23 20:57:22 UTC
Upstream is dropping this so we won't be supporting them.

'Since the fbdev framework is in maintenance mode and all new display
drivers should be made with the DRM framework, remove fbtft from
staging.'

https://lkml.org/lkml/2016/11/23/44


Note You need to log in before you can comment on or make changes to this bug.