Bug 136748 - traceback while doing initial satellite-sync on rhel 2.1
traceback while doing initial satellite-sync on rhel 2.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-10-21 23:12 EDT by Max Spevack
Modified: 2007-07-31 11:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:22:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the full traceback (225.98 KB, text/plain)
2004-10-21 23:17 EDT, Max Spevack
no flags Details

  None (edit)
Description Max Spevack 2004-10-21 23:12:20 EDT
satellite-sync -c rhel-i386-as-3 -c redhat-advanced-server-i386
 rhel2.1-as-u5rhn-satellite-3.6.0-18-redhat-linux-as-i386-2.1-embedded-oracle.iso

The sync is failing with this error -- the email that was sent as a
result of the traceback is much longer, and will be included as an
attachment.

Exception type zlib.error
 
Exception Handler Information
Traceback (innermost last):
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 123, in process
    self.__parser.parse(self.__stream)
  File "/usr/lib/python1.5/site-packages/xml/sax/expatreader.py", line
43, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/lib/python1.5/site-packages/xml/sax/xmlreader.py", line
122, in parse
    buffer = file.read(self._bufsize)
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 791,
in read
    return self.file_obj.read(amt)
  File "/usr/lib/python1.5/site-packages/gzip.py", line 157, in read
    self._read(readsize)
  File "/usr/lib/python1.5/site-packages/gzipstream.py", line 167, in
_read
    uncompress = self.decompress.flush()
error: Error -5 while decompressing
Comment 1 Max Spevack 2004-10-21 23:17:26 EDT
Created attachment 105633 [details]
the full traceback
Comment 2 Mihai Ibanescu 2004-10-22 18:03:50 EDT
I believe this is a transient message. Still would be nice to catch
the error.
Comment 3 Mihai Ibanescu 2004-10-28 14:30:18 EDT
This seems to have been a temporary failure due to QA being flaky.
Comment 4 Todd Warner 2004-10-28 15:11:26 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete)
Comment 5 Todd Warner 2004-10-28 15:58:10 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete) REALLY!
Comment 6 Max Spevack 2004-11-05 21:01:28 EST
Fixed.
Comment 7 Todd Warner 2005-03-22 13:22:48 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.