Bug 136749 - traceback while doing initial satellite-sync on rhel 3
traceback while doing initial satellite-sync on rhel 3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-10-21 23:20 EDT by Max Spevack
Modified: 2007-07-31 11:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:07:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the full traceback (227.38 KB, text/plain)
2004-10-21 23:21 EDT, Max Spevack
no flags Details

  None (edit)
Description Max Spevack 2004-10-21 23:20:46 EDT
satellite-sync -c redhat-advanced-server-i386 -c rhel-i386-as-3
rhn-satellite-3.6.0-19-redhat-linux-as-i386-3-embedded-oracle.iso

The sync is failing with this error -- the email that was sent as a
result of the traceback is much longer, and will be included as an
attachment.

Exception type exceptions.ValueError
 
Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 123, in process
    self.__parser.parse(self.__stream)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/expatreader.py",
line 109, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/xmlreader.py",
line 124, in parse
    buffer = file.read(self._bufsize)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 791,
in read
    return self.file_obj.read(amt)
  File "/usr/lib/python2.2/gzip.py", line 163, in read
    self._read(readsize)
  File "/usr/lib/python2.2/site-packages/gzipstream.py", line 168, in
_read
    self._read_eof()
  File "/usr/lib/python2.2/site-packages/gzipstream.py", line 208, in
_read_eof
    self._gzip.GzipFile._read_eof(self)
  File "/usr/lib/python2.2/gzip.py", line 245, in _read_eof
    raise ValueError, "CRC check failed"
ValueError: CRC check failed
Comment 1 Max Spevack 2004-10-21 23:21:46 EDT
Created attachment 105634 [details]
the full traceback
Comment 2 Mihai Ibanescu 2004-10-28 14:30:23 EDT
This seems to have been a temporary failure due to QA being flaky.
Comment 3 Todd Warner 2004-10-28 15:09:35 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete)
Comment 4 Todd Warner 2004-10-28 15:56:12 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete) REALLY!
Comment 5 Max Spevack 2004-11-06 02:14:32 EST
Fixed -- sat-sync works against -39
Comment 6 Todd Warner 2005-03-22 13:07:44 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.