Bug 1367745 - gparted doesn't run under Wayland
Summary: gparted doesn't run under Wayland
Status: CLOSED DUPLICATE of bug 1397103
Alias: None
Product: Fedora
Classification: Fedora
Component: gparted
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-08-17 11:16 UTC by Peter Robinson
Modified: 2016-12-04 02:23 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-12-04 02:23:36 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1274451 None None None Never

Internal Trackers: 1274451

Description Peter Robinson 2016-08-17 11:16:38 UTC
gparted-0.26.1-1.fc25

$ sudo gparted /dev/sdc
[sudo] password for perobins: 
Created symlink /run/systemd/system/-.mount → /dev/null.
Created symlink /run/systemd/system/boot-efi.mount → /dev/null.
Created symlink /run/systemd/system/boot.mount → /dev/null.
Created symlink /run/systemd/system/home.mount → /dev/null.
Created symlink /run/systemd/system/proc-fs-nfsd.mount → /dev/null.
Created symlink /run/systemd/system/run-user-0.mount → /dev/null.
Created symlink /run/systemd/system/run-user-1000.mount → /dev/null.
Created symlink /run/systemd/system/run-user-42.mount → /dev/null.
Created symlink /run/systemd/system/tmp.mount → /dev/null.
Created symlink /run/systemd/system/var-lib-machines.mount → /dev/null.
Created symlink /run/systemd/system/var-lib-nfs-rpc_pipefs.mount → /dev/null.
No protocol specified

(gpartedbin:7845): Gtk-WARNING **: cannot open display: :0
Removed /run/systemd/system/-.mount.
Removed /run/systemd/system/boot-efi.mount.
Removed /run/systemd/system/boot.mount.
Removed /run/systemd/system/home.mount.
Removed /run/systemd/system/proc-fs-nfsd.mount.
Removed /run/systemd/system/run-user-0.mount.
Removed /run/systemd/system/run-user-1000.mount.
Removed /run/systemd/system/run-user-42.mount.
Removed /run/systemd/system/tmp.mount.
Removed /run/systemd/system/var-lib-machines.mount.
Removed /run/systemd/system/var-lib-nfs-rpc_pipefs.mount.

Comment 1 Mukundan Ragavan 2016-08-19 01:48:50 UTC
Also see https://bugzilla.redhat.com/show_bug.cgi?id=1274451

Comment 2 Mike Fleetwood 2016-08-20 15:15:17 UTC
This is caused by Wayland not allowing processes run as a different user
to display on the desktop.  Therefore using "su" or "sudo" to display a
graphical application doesn't work.

Simple workaround is to run "xhost +local:" in the terminal first.

This is documented in the GParted forum here:
  [SOLVED] How to run GParted on a GNOME on Wayland desktop
  http://gparted-forum.surf4.info/viewtopic.php?id=17446

This bug should be closed as a duplicate of bug 1274451.
(But I don't have permission to do that).

Thanks,
Mike Fleetwood (GParted Developer)

Comment 3 Mukundan Ragavan 2016-08-20 20:27:50 UTC
(In reply to Mike Fleetwood from comment #2)
> 
> This bug should be closed as a duplicate of bug 1274451.
> (But I don't have permission to do that).
> 

yes indeed!

closed as duplicate.

*** This bug has been marked as a duplicate of bug 1274451 ***

Comment 4 Michael Catanzaro 2016-12-03 16:06:32 UTC
Reopening this as per the discussion at https://bugzilla.redhat.com/show_bug.cgi?id=1274451#c33

Comment 5 Mukundan Ragavan 2016-12-04 02:23:36 UTC

*** This bug has been marked as a duplicate of bug 1397103 ***


Note You need to log in before you can comment on or make changes to this bug.