Bug 1367780 - nothing happens when I try to install a local rpm file in gnome-software
Summary: nothing happens when I try to install a local rpm file in gnome-software
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker https://fedoraproject...
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-08-17 12:57 UTC by Kamil Páral
Modified: 2016-11-16 00:47 UTC (History)
7 users (show)

Fixed In Version: gnome-software-3.22.1-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-15 16:09:52 UTC


Attachments (Terms of Use)

Description Kamil Páral 2016-08-17 12:57:45 UTC
Description of problem:
Freshly installed F25. I downloaded google chrome rpm from official website and clicked on it in Nautilus. Gnome Software opened up. I clicked Install, and nothing happened. Clicking Install again didn't help.

packagekitd --verbose said:

14:46:16	PackageKit          CreateTransaction method called
14:46:16	PackageKit          job count now 30
14:46:16	PackageKit          trying to open database '/var/lib/PackageKit/transactions.db'
14:46:16	PackageKit          job count is now at 29
14:46:16	PackageKit          transaction now new
14:46:16	PackageKit          setting sender to :1.62
14:46:16	PackageKit          adding transaction 0x5619fe2754e0
14:46:16	PackageKit          sending object path: '/30_cbdcdeed'
14:46:16	PackageKit          notify::connected
14:46:16	PackageKit          SetHints method called: locale=en_US.UTF-8, background=false, interactive=false, cache-age=4294967295
14:46:16	PackageKit          locale changed to en_US.UTF-8
14:46:16	PackageKit          cache-age changed to -1
14:46:16	PackageKit          GetDetails method called: google-chrome-stable;52.0.2743.116-1;x86_64;local
14:46:16	PackageKit          transaction now ready
14:46:16	PackageKit          changing transaction to exclusive mode
14:46:16	PackageKit          1 transactions in list, 1 committed but not finished
14:46:16	PackageKit          transaction now running
14:46:16	PackageKit          install uid now 1000
14:46:16	PackageKit          install cmdline now PackageKit: get-details
14:46:16	PackageKit          setting role for /30_cbdcdeed to get-details
14:46:16	PackageKit-DNF      got state query with hint (null)
14:46:16	PackageKit-DNF      got state loading-cache with hint (null)
14:46:16	PackageKit-DNF      got state loading-cache with hint (null)
14:46:17	PackageKit-DNF      got state download-repository with hint (null)
14:46:19	PackageKit-DNF      got state loading-cache with hint (null)
14:46:19	PackageKit-DNF      got state loading-cache with hint (null)
14:46:19	PackageKit-DNF      got state loading-cache with hint (null)
14:46:19	PackageKit-DNF      got state loading-cache with hint (null)
14:46:20	PackageKit-DNF      got state loading-cache with hint (null)
14:46:20	PackageKit-DNF      created cached sack DnfSack::release_ver[25]::filelists|remote|unavailable
14:46:20	PackageKit          backend was running for 3486 ms
14:46:20	PackageKit          emitting finished 'success', 3486
14:46:20	PackageKit          transaction now finished
14:46:20	PackageKit          1 transactions in list, 0 committed but not finished
14:46:25	PackageKit          transaction /30_cbdcdeed completed, removing
14:46:25	PackageKit          emitting destroy /30_cbdcdeed

If I try "pkcon install-local ./google-chrome-stable_current_x86_64.rpm" instead, it "works" in that sense that it downloads all dependencies and asks me to confirm installation. If I do, it fails with 

Fatal error: package redhat-lsb-4.1-32.fc25.x86_64 cannot be verified and repo fedora is GPG enabled: package not signed: redhat-lsb-4.1-32.fc25.x86_64.rpm

That is probably a separate issue (F25 packages are still not signed). But gnome-software doesn't seem to do anything, it does not download dependencies, it does not report any error - nothing happens.

I also tested with Skype for Linux Alpha, same issue:
https://www.skype.com/en/download-skype/skype-for-linux/downloading-web/?type=weblinux-rpm


Version-Release number of selected component (if applicable):
PackageKit-1.1.4-0.1.20160805.fc25.x86_64
gnome-software-3.21.4-1.fc25.x86_64
hawkey-0.6.3-2.fc25.x86_64
rpm-4.13.0-0.rc1.41.fc25.x86_64
dnf-1.1.9-3.fc25.noarch

How reproducible:
always for me (for clean installs). but I have seen it start downloading deps once, not sure what was different.

Steps to Reproduce:
1. install clean F25 Workstation from Live into VM
2. download google-chrome from https://www.google.com/chrome/
3. double-click on the rpm
4. click Install in gnome-software

Comment 1 Kamil Páral 2016-08-17 13:00:11 UTC
This seems to violate:
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. "
https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality

Installing local RPM files is likely considered a basic functionality of a package manager.

Comment 2 Kamil Páral 2016-08-18 08:28:56 UTC
(In reply to Kamil Páral from comment #0)
> Fatal error: package redhat-lsb-4.1-32.fc25.x86_64 cannot be verified and
> repo fedora is GPG enabled: package not signed:
> redhat-lsb-4.1-32.fc25.x86_64.rpm
> 
> That is probably a separate issue (F25 packages are still not signed).

I modified the repo files to say gpgcheck=0 and the issue is still present for gnome-software. So this is not about unsigned packages.

Comment 3 Geoffrey Marr 2016-08-22 22:23:57 UTC
Discussed during the 2016-08-22 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as installing a local RPM constitutes 'basic functionality' for Software, thus this violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-22/f25-blocker-review.2016-08-22-16.00.txt

Comment 4 Richard Hughes 2016-09-28 12:03:50 UTC
(In reply to Kamil Páral from comment #0)
> F25 packages are still not signed

I'm still not sure "turning on" signing at the 11th hour is a good idea for testing a release. Didn't we talk about enabling the signing after the branch each release? I'm getting too old for post-beta bugs about package signing as I've seen it about 3 times before...

Regardless, I'll work on the error path bug you've found here today.

Comment 5 Richard Hughes 2016-09-28 14:42:27 UTC
I've just downloaded and installed http://dl.fedoraproject.org/pub/fedora/linux/development/25/Workstation/x86_64/iso/ in gnome-boxes, did "sudo dnf update", downloaded the google chrome rpm, double clicked it and it installed fine on gnome-software. Could you verify this bug is still valid please? Thanks.

Comment 6 Kamil Páral 2016-10-03 11:17:16 UTC
I tried with a fully updated VM, then with a default install of Fedora-Workstation-Live-x86_64-25-20161002.n.0.iso, and then with that installation fully updated. I can't make it work, click on Install does nothing. How can I help you debug it?

Comment 7 Kamil Páral 2016-10-03 12:22:31 UTC
This seems to be fixed if I restart gnome-software process. But after login (when it's running as /usr/bin/gnome-software --gapplication-service) or when gnome-software process is killed and started from nautilus by clicking on RPM, this bug occurs.

Comment 8 Kamil Páral 2016-10-04 09:09:27 UTC
This is being worked on, this scratch build [1] seems to fix the issue.
[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=15933292

Comment 9 Fedora Update System 2016-10-14 04:56:56 UTC
accerciser-3.22.0-1.fc25, cheese-3.22.1-2.fc25, cogl-1.22.2-2.fc25, control-center-3.22.1-1.fc25, dconf-editor-3.22.1-1.fc25, eog-3.20.5-1.fc25, eog-plugins-3.16.5-1.fc25, epiphany-3.22.1-1.fc25, evince-3.22.1-1.fc25, evolution-3.22.1-2.fc25, evolution-data-server-3.22.1-1.fc25, evolution-ews-3.22.1-1.fc25, file-roller-3.22.1-1.fc25, gdm-3.22.1-1.fc25, ghex-3.18.3-1.fc25, glib2-2.50.1-1.fc25, gnome-backgrounds-3.22.1-1.fc25, gnome-boxes-3.22.1-1.fc25, gnome-builder-3.22.1-1.fc25, gnome-calculator-3.22.1-1.fc25, gnome-clocks-3.22.1-1.fc25, gnome-color-manager-3.22.1-1.fc25, gnome-desktop3-3.22.1-1.fc25, gnome-devel-docs-3.22.1-2.fc25, gnome-initial-setup-3.22.1-1.fc25, gnome-logs-3.22.1-2.fc25, gnome-maps-3.22.1-1.fc25, gnome-mines-3.22.1-1.fc25, gnome-multi-writer-3.22.1-1.fc25, gnome-music-3.22.1-1.fc25, gnome-nibbles-3.22.1-1.fc25, gnome-online-accounts-3.22.1-1.fc25, gnome-packagekit-3.22.1-1.fc25, gnome-power-manager-3.22.1-1.fc25, gnome-session-3.22.1-1.fc25, gnome-settings-daemon-3.22.1-1.fc25, gnome-shell-3.22.1-1.fc25, gnome-shell-extensions-3.22.1-1.fc25, gnome-software-3.22.1-1.fc25, gnome-themes-standard-3.22.2-1.fc25, gthumb-3.4.4.1-1.fc25, gtk3-3.22.1-2.fc25, gupnp-av-0.12.9-1.fc25, gvfs-1.30.1-1.fc25, libappstream-glib-0.6.4-1.fc25, libgee-0.18.1-1.fc25, mutter-3.22.1-2.fc25, orca-3.22.1-1.fc25, polari-3.22.1-1.fc25, rygel-0.32.1-1.fc25, sysprof-3.22.1-1.fc25, vala-0.34.1-1.fc25, webkitgtk4-2.14.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9680599aab

Comment 10 Kamil Páral 2016-10-14 11:26:39 UTC
Seems to be fixed.

Comment 11 Fedora Update System 2016-10-15 16:09:52 UTC
accerciser-3.22.0-1.fc25, cheese-3.22.1-2.fc25, cogl-1.22.2-2.fc25, control-center-3.22.1-1.fc25, dconf-editor-3.22.1-1.fc25, eog-3.20.5-1.fc25, eog-plugins-3.16.5-1.fc25, epiphany-3.22.1-1.fc25, evince-3.22.1-1.fc25, evolution-3.22.1-2.fc25, evolution-data-server-3.22.1-1.fc25, evolution-ews-3.22.1-1.fc25, file-roller-3.22.1-1.fc25, gdm-3.22.1-1.fc25, ghex-3.18.3-1.fc25, glib2-2.50.1-1.fc25, gnome-backgrounds-3.22.1-1.fc25, gnome-boxes-3.22.1-1.fc25, gnome-builder-3.22.1-1.fc25, gnome-calculator-3.22.1-1.fc25, gnome-clocks-3.22.1-1.fc25, gnome-color-manager-3.22.1-1.fc25, gnome-desktop3-3.22.1-1.fc25, gnome-devel-docs-3.22.1-2.fc25, gnome-initial-setup-3.22.1-1.fc25, gnome-logs-3.22.1-2.fc25, gnome-maps-3.22.1-1.fc25, gnome-mines-3.22.1-1.fc25, gnome-multi-writer-3.22.1-1.fc25, gnome-music-3.22.1-1.fc25, gnome-nibbles-3.22.1-1.fc25, gnome-online-accounts-3.22.1-1.fc25, gnome-packagekit-3.22.1-1.fc25, gnome-power-manager-3.22.1-1.fc25, gnome-session-3.22.1-1.fc25, gnome-settings-daemon-3.22.1-1.fc25, gnome-shell-3.22.1-1.fc25, gnome-shell-extensions-3.22.1-1.fc25, gnome-software-3.22.1-1.fc25, gnome-themes-standard-3.22.2-1.fc25, gthumb-3.4.4.1-1.fc25, gtk3-3.22.1-2.fc25, gupnp-av-0.12.9-1.fc25, gvfs-1.30.1-1.fc25, libappstream-glib-0.6.4-1.fc25, libgee-0.18.1-1.fc25, mutter-3.22.1-2.fc25, orca-3.22.1-1.fc25, polari-3.22.1-1.fc25, rygel-0.32.1-1.fc25, sysprof-3.22.1-1.fc25, vala-0.34.1-1.fc25, webkitgtk4-2.14.1-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Christian Stadelmann 2016-11-15 22:45:18 UTC
Since this bug is reported as fixed, how about removing it from https://fedoraproject.org/wiki/Common_F25_bugs#gnome-software-local-rpm ?

Comment 13 Michael Catanzaro 2016-11-16 00:47:14 UTC
(In reply to Christian Stadelmann from comment #12)
> Since this bug is reported as fixed, how about removing it from
> https://fedoraproject.org/wiki/Common_F25_bugs#gnome-software-local-rpm ?

OK, done.


Note You need to log in before you can comment on or make changes to this bug.