Bug 136787 - Need option for panel to span multiple screens
Need option for panel to span multiple screens
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 08:06 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 10:00:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-22 08:06:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
It would be nice if the panel could span multiple screens.
Currently a panel is needed for each screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Mark McLoughlin 2004-10-28 10:00:28 EDT
Best thing to do is add some rationale as to why there's a need for
both behaviours as opposed to one or the other. Alternatively, explain
why you think spanning the entire screen is always the right thing:

  http://bugzilla.gnome.org/show_bug.cgi?id=73475

Comment 2 Need Real Name 2004-10-28 10:12:39 EDT
There is a need for both behaviours because there is a need for both
setups.

If you have two monitors next to each other, with no (or little) join
between the two, then what you really have, in effect, is a single
wide monitor. Spanning the entire screen is the right thing to do.

If you have two monitors near each other, with a gap between them,
then it makes more sense that the monitors are treated separately.

Allowing a panel to be sized horizontally would fix this bug (a
preference would be a nicer fix though).
Comment 3 Mark McLoughlin 2004-10-28 10:20:45 EDT
Sorry, I should have been more clear - please add your comments to the
upstream bug report

Note You need to log in before you can comment on or make changes to this bug.