Bug 1368031 - The instruction in haproxy-config.template is incomplete
Summary: The instruction in haproxy-config.template is incomplete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Ben Bennett
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-18 07:39 UTC by Meng Bo
Modified: 2017-03-08 18:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Comment in template was incomplete. Consequence: People reading the template would be confused. Fix: Complete the comment. Result: Less confusion.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:44:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Origin (Github) 10506 None None None 2016-08-18 14:05:12 UTC

Description Meng Bo 2016-08-18 07:39:16 UTC
Description of problem:
Check the haproxy-config.template and find the "app level backend" section,
The 3rd point in the instruction is incomplete.

https://github.com/openshift/origin/blob/master/images/router/haproxy/conf/haproxy-config.template#L230

Version-Release number of selected component (if applicable):
3.3.0.22

How reproducible:
always

Steps to Reproduce:
1. Check the haproxy-config.template
2.
3.

Actual results:
The instruction is incomplete.

Expected results:


Additional info:

Comment 1 openshift-github-bot 2016-08-18 22:09:24 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/c0b7f664db8ea9b0a62c989b4d79a83cc480e3b9
Fixed the comment about the different backends we make

Filled in the rest of the comment about the pass-through case.  Made
the comment cover the additional edge termination case.  Clarified the
wording to make it clear what happens for each termination type.

Fixes bug 1368031

Comment 2 Troy Dawson 2016-09-01 15:58:31 UTC
This has been merged into ose and is in OSE v3.3.0.28 or newer.

Comment 4 Meng Bo 2016-09-02 05:50:35 UTC
Checked on router image openshift3/ose-haproxy-router:v3.3.0.28 6ff97e2fd698

Issue has been fixed.

Comment 6 errata-xmlrpc 2016-09-27 09:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.