Bug 1368050 - Should also set the connection limits for reencrypt and passthrough termination routes
Summary: Should also set the connection limits for reencrypt and passthrough terminati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: jtanenba
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-18 08:34 UTC by Meng Bo
Modified: 2016-09-27 09:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:44:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Origin (Github) 10513 None None None 2016-08-18 19:56:51 UTC

Description Meng Bo 2016-08-18 08:34:03 UTC
Description of problem:
From PR https://github.com/openshift/origin/pull/9810, the connection limits are set for edge route(be_edge_http_*) and insecure route(be_http_*), but the reencrypt(be_secure_*) and passthrough route(be_tcp_*) does not have the configuration.


Version-Release number of selected component (if applicable):
openshift v3.3.0.22
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git
openshift3/ose-haproxy-router    v3.3.0.22           185850e07ab4

How reproducible:
always

Steps to Reproduce:
1. Create route with each type
2. Set the connection limits to the routes via annotation
$ oc annotate route route haproxy.router.openshift.io/rate-limit-connections=true
$ oc annotate route route haproxy.router.openshift.io/rate-limit-connections.rate-tcp=6
3. Check the haproxy config

Actual results:
The edge route and unsecure route has the rate-limit-connections applied, but the reencrypt route and passthrough route does not have.

Expected results:
All the types of route should have the configuration.

Additional info:

Comment 2 Meng Bo 2016-08-23 08:19:34 UTC
Checked on build v3.3.0.24

Issue fixed.

The reencrypt and passthrough routes can set the connection limits now.

Comment 4 errata-xmlrpc 2016-09-27 09:44:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.