Bug 13681 - USB printer communication shaky
USB printer communication shaky
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Winston rc1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-10 19:29 EDT by Trond Eivind Glomsrxd
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 05:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond Eivind Glomsrxd 2000-07-10 19:29:07 EDT
When printing a page on a USB printer, the job often stops somewhere in the
job (e.g. after half a page). When using the same printer with a parallell
port, the jobs goes through. Communication problems?
Comment 1 Glen Foster 2000-07-30 18:40:02 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 2 Tim Waugh 2000-08-01 06:08:57 EDT
Does it stop altogether?  With the USB in 2.4.0-testxx I was seeing occasional
long delays with USB, which seemed to go away with test5.  Perhaps there are
some backported fixes we need?
Comment 3 Trond Eivind Glomsrxd 2000-08-01 07:45:28 EDT
Yes, it stops altogether. Please check for important fixes in test5 (there are
some wrt. USB storage as well, which I would like backported... possibly more)
Comment 4 Tim Waugh 2000-08-03 08:22:48 EDT
Is this with ohci, uhci or usb-uhci by the way?  I don't know the USB code very
well so I'm not sure which changes we want..
Comment 5 Trond Eivind Glomsrxd 2000-08-03 09:39:38 EDT
uhci

Printing works fine with a USB-to-parallell-port converter, BTW - but not with
the native USB driver.
Comment 6 Tim Waugh 2000-08-04 05:24:50 EDT
Does 2.2.16-18 make things any better?
Comment 7 Trond Eivind Glomsrxd 2000-08-07 12:12:20 EDT
yes, it works fine now.

Note You need to log in before you can comment on or make changes to this bug.