Bug 136814 - mkinitrd rpm should require cpio
Summary: mkinitrd rpm should require cpio
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-22 14:35 UTC by Steve Hill
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 11:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hill 2004-10-22 14:35:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
mkinitrd RPM does not list cpio as a dependency even though it's
operations does depend on cpio being present.  This means that it may
be installed without cpio present and so will not work.

Version-Release number of selected component (if applicable):
4.1.12-1

How reproducible:
Always

Steps to Reproduce:
1. Install mkinitrd on system without cpio
2. Execute mkinitrd


Actual Results:  Fails to complete execution, citing inability to
execute /bin/cpio

Expected Results:  Should have failed to install RPM due to dependence
on cpio (or in the case of yum, should have installed cpio as a
dependency)

Additional info:

Comment 1 Jeremy Katz 2004-10-24 21:54:35 UTC
Fixed in 4.1.18-2 

Comment 2 Steve Hill 2004-11-01 11:11:35 UTC
Checked version 4.1.18-2 - bug is fixed, changed to WORKSFORME


Note You need to log in before you can comment on or make changes to this bug.