Bug 1368254 - Handle errata status with Library vs current environment
Summary: Handle errata status with Library vs current environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Errata Management
Version: 6.2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1372840 1376224 (view as bug list)
Depends On:
Blocks: 1394360
TreeView+ depends on / blocked
 
Reported: 2016-08-18 20:33 UTC by Nagoor Shaik
Modified: 2021-03-11 14:39 UTC (History)
20 users (show)

Fixed In Version: tfm-rubygem-katello-3.0.0.86-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1394360 (view as bug list)
Environment:
Last Closed: 2016-12-12 17:13:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 12347 0 High Closed Handle errata status with Library vs current environment 2020-10-13 18:55:48 UTC
Red Hat Knowledge Base (Solution) 2623651 0 None None None 2020-09-10 09:47:43 UTC
Red Hat Knowledge Base (Solution) 2678781 0 None None None 2016-10-03 09:06:19 UTC
Red Hat Product Errata RHBA-2016:2940 0 normal SHIPPED_LIVE Satellite 6.2.5 Async Bug Release 2016-12-12 22:08:21 UTC

Description Nagoor Shaik 2016-08-18 20:33:40 UTC
Description of problem:
Currently the errata only looks at all applicable errata, and does not handle 'installable errata'

Some users may only care about installable errata, and it may be useful to query based on installable errata status.

Version-Release number of selected component (if applicable):
Satellite 6.2.1

How reproducible:
100%

Steps to Reproduce:
1. Create a Content View and register a client to that specific content-view
2. Patch the system fully 
3. Check the over all status of the host which shows "Error" and the Errata status shows "Security errata applicable"

Actual results:
Overall status shows Error, even in case of a fully patched system (where no installable errat

Expected results:
So it may make sense to have two different errata status:

installable errata
applicable errata

each with security/non_security/none states

And the user could decide (via a setting) whether or not to use each one to build the global status.

Additional info:

Comment 3 Chris Roberts 2016-10-04 21:31:54 UTC
*** Bug 1376224 has been marked as a duplicate of this bug. ***

Comment 4 Bryan Kearney 2016-10-12 22:02:27 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/12347 has been resolved.

Comment 6 Roman Plevka 2016-12-07 12:19:20 UTC
VERIFIED

# rpm -qa satellite
satellite-6.2.5-1.0.el7sat.noarch

- created a CV with filter to exclude some errata.
- subscribed host
- got an applicable errata.

- with settings -> katello -> errata_status_installable set to TRUE,
the host's status is green - "All errata applied".
Setting it to 'FALSE' makes it a warning.

Comment 7 errata-xmlrpc 2016-12-12 17:13:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940

Comment 8 Kathryn Dixon 2017-07-11 22:46:51 UTC
*** Bug 1372840 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.