Bug 1368331 - gnome-session has warning messages
Summary: gnome-session has warning messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-session
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1522983 1274381
TreeView+ depends on / blocked
 
Reported: 2016-08-19 05:55 UTC by Huaisheng
Modified: 2020-08-13 08:33 UTC (History)
14 users (show)

Fixed In Version: gnome-session-3.26.1-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 12:55:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages (5.40 MB, text/plain)
2016-08-19 05:55 UTC, Huaisheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 12:57:08 UTC

Description Huaisheng 2016-08-19 05:55:55 UTC
Created attachment 1192032 [details]
/var/log/messages

Description of problem:

RHEL7.3 have some gnome error in messages log file

Version-Release number of selected component (if applicable):
gnome-session-3.14.0-5.el7

How reproducible:


Steps to Reproduce:
1. Full install RHEL7.3Alpha1 on X3650M5 with UEFI mode
2. Boot into OS and check /var/log/message 

Actual results:
Have found there were some error info about gnome-session in messages log file.

Expected results:
No error or warning info.

Additional info:

[root@localhost log]# cat messages | grep -i error
Aug  9 03:45:55 localhost gnome-keyring-daemon[27220]: couldn't create login keyring: An error occurred on the device
Aug  9 03:47:05 localhost gnome-session: (gnome-settings-daemon:27444): smartcard-plugin-WARNING **: Got potentially spurious smartcard event error: ffffe098.
Aug 10 07:29:35 localhost gnome-session[2690]: WARNING: Error getting login monitor: -13
Aug 11 00:12:37 localhost gnome-session: gnome-session[17553]: WARNING: Error getting login monitor: -13
Aug 11 00:13:21 localhost gnome-session: (gnome-settings-daemon:17595): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: The connection is closed
Aug 11 00:13:24 localhost gnome-session: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by IMSettings

[root@localhost log]# cat messages | grep -i fail
Aug  9 03:45:55 localhost gnome-keyring-daemon[27220]: failed to unlock login keyring on startup
Aug 11 00:12:38 localhost gnome-settings-daemon: ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tokens/
Aug 11 00:13:22 localhost gnome-session: (gnome-settings-daemon:18131): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Aug 11 00:13:24 localhost gnome-session: Failed to play sound: File or data not found
Aug 11 00:13:24 localhost gnome-session: (gnome-shell:18155): mutter-WARNING **: Failed to load background '/usr/share/backgrounds/gnome/adwaita-lock.jpg': Failed to open file '/usr/share/backgrounds/gnome/adwaita-lock.jpg': No such file or directory


[root@localhost log]# cat messages | grep -i warning
Aug 11 00:09:01 localhost gnome-session: (gnome-shell:2867): GLib-GObject-WARNING **: g_object_notify: object class 'UpClient' has no property named 'g-name-owner'
Aug 11 00:09:01 localhost gnome-session: (gnome-settings-daemon:2762): GLib-GObject-WARNING **: g_object_notify: object class 'UpDevice' has no property named 'g-name-owner'
Aug 11 00:13:21 localhost gnome-session: (gnome-settings-daemon:17595): GLib-GIO-WARNING **: Invalid id 5 passed to g_bus_unown_name()
Aug 11 00:13:22 localhost gnome-session: gnome-session[17910]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Aug 11 00:13:22 localhost gnome-session[17910]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Aug 11 00:13:22 localhost gnome-session: Gjs-Message: JS WARNING: [resource:///org/gnome/shell/ui/extensionSystem.js 301]: octal literals and octal escape sequences are deprecated
Aug 11 00:13:22 localhost gnome-session: Gjs-Message: JS WARNING: [resource:///org/gnome/shell/gdm/loginDialog.js 1017]: anonymous function does not always return a value
Aug 11 00:13:23 localhost gnome-session: Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/launch-new-instance@gnome-shell-extensions.gcampax.github.com/extension.js 9]: assignment to undeclared variable _activateOriginal
Aug 11 00:13:24 localhost gnome-session: (nautilus:18291): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -15 and height 34
Aug 11 00:13:24 localhost gnome-session: (gnome-settings-daemon:18131): color-plugin-WARNING **: failed to get edid: unable to get EDID for output
Aug 11 00:13:24 localhost gnome-session: (gnome-shell:18155): mutter-WARNING **: STACK_OP_ADD: window 0x2000001 already in stack
Aug 11 00:15:38 localhost gnome-session: (gnome-settings-daemon:18131): color-plugin-WARNING **: unable to get EDID for xrandr-VGA-0: unable to get EDID for output

Comment 3 Huaisheng 2016-09-05 05:33:23 UTC
Hi,

If these error and warning messages are harmless or working as designed, please let me know it.

Thanks,
Huaisheng

Comment 4 Ray Strode [halfline] 2016-09-06 14:38:06 UTC
Hi,

These bugs are harmless, but they are indeed bugs none the less, and we should fix them.

I think most of these bugs are already filed as separate reports.  I need to do some searching and report back.

Comment 5 Huaisheng 2016-09-06 15:38:37 UTC
(In reply to Ray Strode [halfline] from comment #4)
> Hi,
> 
> These bugs are harmless, but they are indeed bugs none the less, and we
> should fix them.
> 
> I think most of these bugs are already filed as separate reports.  I need to
> do some searching and report back.

Sure, waiting for your good news, and anything we could help please let us know it.

Comment 6 Debarshi Ray 2017-07-24 13:49:08 UTC
Maybe we can repurpose this bug for:
https://bugzilla.gnome.org/show_bug.cgi?id=784339
https://bugzilla.gnome.org/show_bug.cgi?id=784349

At least the 2nd one would lead to GLib-GIO-CRITICALs due to a bug in gnome-session itself.

Comment 7 Ray Strode [halfline] 2017-08-11 14:10:46 UTC
sounds reasonable

Comment 8 Ray Strode [halfline] 2017-10-30 13:44:40 UTC
so the issues in comment 6 got fixed by rebase.

Comment 14 errata-xmlrpc 2018-04-10 12:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.