Bug 1368343 - Failed to run docker/upgrade.yml playbook independently
Summary: Failed to run docker/upgrade.yml playbook independently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 06:42 UTC by Anping Li
Modified: 2016-09-27 09:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:45:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Anping Li 2016-08-19 06:42:16 UTC
Description of problem:
there are no nuke_images.sh under /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades. so it failed to run docker/upgrade.yaml playbook independently.


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.3.12-1

How reproducible:
always

Steps to Reproduce:
1. ansible-playbook /root/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/docker/upgrade.yml

2. grep -B 2 -A 3 nuke_images.sh /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades/docker/upgrade.yml
- name: Remove all containers and images
  script: nuke_images.sh docker
  register: nuke_images_result
  when: docker_upgrade_nuke_images is defined and docker_upgrade_nuke_images | bool

Actual results:
TASK [Remove all containers and images] ****************************************
fatal: [host4master.example.com]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to find 'nuke_images.sh' in expected paths."}

NO MORE HOSTS LEFT *************************************************************
    to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/docker/upgrade.retry

PLAY RECAP *********************************************************************
host4master.example.com    : ok=21   changed=3    unreachable=0    failed=1   
host4node.example.com      : ok=16   changed=0    unreachable=0    failed=0   
localhost                  : ok=8    changed=6    unreachable=0    failed=0   


Expected results:


Additional info:

Comment 1 Devan Goodwin 2016-08-19 14:55:06 UTC
Fixed in https://github.com/openshift/openshift-ansible/pull/2331

Comment 3 Anping Li 2016-08-23 02:48:32 UTC
The standalone Docker upgrade works using master branch, waiting this PR in v3 branch.

Comment 4 Anping Li 2016-08-23 03:01:06 UTC
(In reply to Anping Li from comment #3)
> The standalone Docker upgrade works using master branch, waiting this PR in
> v3 branch.

I mean this PR isn't in the latest RPM packages( Now the latest one is openshift-ansible-3.3.13-1).

Comment 8 errata-xmlrpc 2016-09-27 09:45:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.