Bug 136837 - "runaway loop modprobe" on startup
"runaway loop modprobe" on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 12:22 EDT by Michal Jaegermann
Modified: 2015-01-04 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 18:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-22 12:22:45 EDT
Description of problem:

I got the following while booting kernel-2.6.9-1.639 on x86_64
.....
Probing IDE interface ide0...
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
Probing IDE interface ide1...
.....

Eventually the whole thing boots so this is easy to miss
if one is not checking for it.

Version-Release number of selected component (if applicable):
mkinitrd-4.1.18-1

How reproducible:
Not clear.  Yesterday looked quite reproducible to me.  Now I
cannot reproduce using either 2.6.9-1.639 or 2.6.9-1.640 kernels.
Originally I thought that this may be related to segfaults in
udev but Harald asked me to refile under mkinitrd.

I do not have yet fixed udev while attempting to reproduce and
all initrd images where this showed up, or not, were done with
mkinitrd-4.1.18-1.
Comment 1 Bill Nottingham 2004-10-22 21:04:45 EDT
net-pf-1 is unix domain sockets. Considering that that pretty much
*has* to be built into the kernel, that's a very odd message.

Assigning to kernel; that message is coming before mkinitrd.
Comment 2 Dave Jones 2004-10-25 15:15:52 EDT
indeed, and CONFIG_UNIX=y in current kernels (and has been since ever
afaik). this smells like a userspace bug to me.
Comment 3 Michal Jaegermann 2004-10-25 15:25:55 EDT
This was apparently a "bad day" when I noticed that "runaway loop".
I had no troubles to get that then and I could not reproduce this
ever after.  It is possible that with quick pace of updates something
was changed which made it to disappear.

Note You need to log in before you can comment on or make changes to this bug.