Bug 1368390 - Display id in warning log should be consistent with display id in view->displays->display X
Summary: Display id in warning log should be consistent with display id in view->displ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.3
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Snir Sheriber
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 09:11 UTC by Xiaodai Wang
Modified: 2017-08-01 15:04 UTC (History)
7 users (show)

Fixed In Version: virt-viewer-5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1849 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2017-08-01 17:49:46 UTC

Description Xiaodai Wang 2016-08-19 09:11:20 UTC
Description of problem:
Display id in warning log should be consistent with display id in view->displays->display X

Version-Release number of selected component (if applicable):
virt-viewer-2.0-11.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make sure there is only 1 physical monitor on host.
2. Open a spice guest by virt-viewer and enable display 1 and display 4. 
3. Close the virt-viewer window.
4. Open the guest by "virt-viewer $guest -f".

Actual results:
$ virt-viewer -c qemu:///system rhel7.2 -f

(virt-viewer:14484): virt-viewer-WARNING **: display 3 should not be enabled, disabling

Expected results:
The display id in the warning message should begin from 1 and be consistent with display id in "view->displays->display x"  menu item.

Additional info:

Comment 2 Pavel Grunt 2016-08-19 10:57:06 UTC
Ideally the warning should not be triggered at all, lets fix it for 7.4

Comment 6 Xiaodai Wang 2017-03-20 05:46:21 UTC
I verified it with virt-viewer-5.0-2.el7.x86_64. 

The display ID in debug log is consistent with the id of "view->displays->display x".

(virt-viewer:24494): virt-viewer-DEBUG: display 2 should not be enabled, disabling
(virt-viewer:24494): virt-viewer-DEBUG: monitor for display 2 does not exist
(virt-viewer:24494): virt-viewer-DEBUG: display 3 should not be enabled, disabling
(virt-viewer:24494): virt-viewer-DEBUG: monitor for display 3 does not exist
(virt-viewer:24494): virt-viewer-DEBUG: display 4 should not be enabled, disabling

So move the bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2017-08-01 15:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1849


Note You need to log in before you can comment on or make changes to this bug.