Bug 1368424 - Unable to view certificates issued by Sub CA in Web UI
Summary: Unable to view certificates issued by Sub CA in Web UI
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 11:02 UTC by Abhijeet Kasurde
Modified: 2016-11-04 06:01 UTC (History)
5 users (show)

(edit)
The IdM web UI shows certificates issued by sub-CAs as expected

To display the certificates issued by a certificate authority (CA), the IdM web UI uses the "ipa cert-find" command to query the CA name, and then the "ipa cert-show" command. Previously, "ipa cert-show" did not use the CA name. As a consequence, attempting to display the details page for a certificate issued by a sub-CA failed with an error in the web UI. This bug has been fixed, and the web UI now displays the details pages for certificates as expected.
Clone Of:
(edit)
Last Closed: 2016-11-04 06:01:39 UTC


Attachments (Terms of Use)
cert_details.png (63.69 KB, image/png)
2016-08-19 11:02 UTC, Abhijeet Kasurde
no flags Details
subca_issuer.png (152.51 KB, image/png)
2016-09-09 05:08 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-08-19 11:02:12 UTC
Created attachment 1192103 [details]
cert_details.png

Description of problem:
Web UI fails to show certificates issued by Sub-CA


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-8.el7.x86_64

How reproducible:
100% 

Steps to Reproduce:
1. Generate CSR 
2. ipa cert-request --ca=SampleSubCA1 with CSR and Principal
3. Goto web ui 'cert/details/'

Actual results:
IPA Web UI fails to show certificates issued by Sub-CA

Expected results:
IPA Web UI should show certificates issued by Sub-CA

Comment 2 Petr Vobornik 2016-08-22 08:27:03 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6238

Comment 9 Abhijeet Kasurde 2016-09-09 05:08 UTC
Created attachment 1199287 [details]
subca_issuer.png

Verified using IPA version ::
ipa-server-4.4.0-10.el7.x86_64

Steps used for verification ::

1. Generate CSR
2. ipa cert-request --ca=SampleSubCA1 with CSR and Principal
3. Goto web ui 'cert/details/' and verify if Certificate generated is issued by Sub CA

Comment 13 errata-xmlrpc 2016-11-04 06:01:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.