Bug 1368442 - New Package Request: openstack-tripleo-validations
Summary: New Package Request: openstack-tripleo-validations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Mike Burns
URL:
Whiteboard:
: 1374975 (view as bug list)
Depends On: 1361581
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 12:10 UTC by Mike Burns
Modified: 2016-12-14 15:52 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-validations-5.1.1-0.20160916003020.3652f12.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1361581
Environment:
Last Closed: 2016-12-14 15:52:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Mike Burns 2016-08-19 12:10:37 UTC
+++ This bug was initially created as a clone of Bug #1361581 +++

Spec URL: https://tokyo.mandre.org/~martin/packaging/openstack-tripleo-validations.spec
SRPM URL: https://tokyo.mandre.org/~martin/packaging/openstack-tripleo-validations-0.0.1-1.fc24.src.rpm
Description: A collection of Ansible playbooks to detect and report potential issues during TripleO deployments.

--- Additional comment from Martin André on 2016-07-29 10:15:13 EDT ---

I've moved the spec file to https://github.com/mandre/tripleo-validations-packaging, I figured it would be easier to respond to feedback if I versionate my changes.

Added html documentation and test subpackage.

--- Additional comment from Chandan Kumar on 2016-08-01 01:01:43 EDT ---

Hello Martin,

Thanks for submitting for Package Review:

Below is my comments:

[1.] Replace Version: and Release: fields to 'XXX' as dlrn takes both of these from the tags set on the git repositories

[2.] include python-pbr and python-setuptools to Requires also.

[3.] remove this line rm -rf *.egg-info, please do not delete egg files, it contains text fixtures which does not get copied under %{python2_sitelib}/<pypi_module>/tests folders.

[4.] please include Build Requires and Requires for openstack-tripleo-validations-tests based on packages present in test-requirements.txt

and also include Requires: %{name} = %{version}-%{release}

[5.] include
%check
%{__python2} setup.py testr to run the tests while building the rpms.

[6.] For Building Documentation you can simply use:

Add this line above in the spec file:
%global with_doc %{!?_without_doc:1}%{?_without_doc:0}

# docs generation
export PYTHONPATH="$( pwd ):$PYTHONPATH"
pushd doc
%if 0%{?with_doc}
SPHINX_DEBUG=1 sphinx-build -b html source build/html
# Fix hidden-file-or-dir warnings
rm -fr build/html/.doctrees build/html/.buildinfo
%endif
popd 

[7.] Since docs are not so big, please include it under %files section
as %doc doc/build/html

[8.] Include egg files in %files section

%{python2_sitelib}/*-*.egg-info

[9.] These two lines are not required:
%{_datadir}/%{name}
+%{_defaultdocdir}/%{name}

Rest looks ok to me.

Thanks,

Chandan Kumar

--- Additional comment from Martin André on 2016-08-01 02:55:48 EDT ---

Thanks Chandan for the very thorough review. I've created the tripleo-validations spec file based on the one of tripleo-common and other information I could find on RDO website but apparently missed quite a few things.

(In reply to Chandan Kumar from comment #2)
> Hello Martin,
> 
> Thanks for submitting for Package Review:
> 
> Below is my comments:
> 
> [1.] Replace Version: and Release: fields to 'XXX' as dlrn takes both of
> these from the tags set on the git repositories

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/51b40f927d1420512ae664eb559395ac29620763

> [2.] include python-pbr and python-setuptools to Requires also.

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/1b2908852128a3cac84bda1815c0b630ae364df4

> [3.] remove this line rm -rf *.egg-info, please do not delete egg files, it
> contains text fixtures which does not get copied under
> %{python2_sitelib}/<pypi_module>/tests folders.

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/1308d380d422c00fc03d29550fb46d84458ec2f3

> [4.] please include Build Requires and Requires for
> openstack-tripleo-validations-tests based on packages present in
> test-requirements.txt

I'm not too sure about what should be in Requires and BuildRequires for the test package. I've looked at other spec files but couldn't find a package in RDO which has more than the "Requires: %{name} = %{version}-%{release}" line.

> and also include Requires: %{name} = %{version}-%{release}

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/5604bfcde9fe428b56e9ffb8a2ced2abc2462c68

> [5.] include
> %check
> %{__python2} setup.py testr to run the tests while building the rpms.

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/49d33ac3681a86028e7b2b21c1137017b42c5842

> [6.] For Building Documentation you can simply use:
> 
> Add this line above in the spec file:
> %global with_doc %{!?_without_doc:1}%{?_without_doc:0}
> 
> # docs generation
> export PYTHONPATH="$( pwd ):$PYTHONPATH"
> pushd doc
> %if 0%{?with_doc}
> SPHINX_DEBUG=1 sphinx-build -b html source build/html
> # Fix hidden-file-or-dir warnings
> rm -fr build/html/.doctrees build/html/.buildinfo
> %endif
> popd 

Done.
https://github.com/mandre/tripleo-validations-packaging/commit/4f442b3fe76c38551fddf7809e60e4eb321fbfd3

> [7.] Since docs are not so big, please include it under %files section
> as %doc doc/build/html
> 
> [8.] Include egg files in %files section
> 
> %{python2_sitelib}/*-*.egg-info
> 
> [9.] These two lines are not required:
> %{_datadir}/%{name}
> +%{_defaultdocdir}/%{name}

7, 8, and 9 done in https://github.com/mandre/tripleo-validations-packaging/commit/5223b90950d0aa04ac43b21589fd3afdfe8bf562

> Rest looks ok to me.
> 
> Thanks,
> 
> Chandan Kumar

--- Additional comment from Martin André on 2016-08-02 08:37:53 EDT ---

Just a little update: I was able to successfully build tripleo-validations package with spec file at https://raw.githubusercontent.com/mandre/tripleo-validations-packaging/bde878b7482eac1945e76d7348c16a01b4a9bde6/openstack-tripleo-validations.spec

I needed https://review.openstack.org/#/c/322178/ in tripleo-validations though, otherwise the build fails due to missing /usr/share/openstack-tripleo-validations directory.

--- Additional comment from Jason E. Rist on 2016-08-17 09:32:24 EDT ---

Martin it looks like 322178 was merged, what's the next step?

Comment 1 Mike Burns 2016-09-12 12:30:14 UTC
*** Bug 1374975 has been marked as a duplicate of this bug. ***

Comment 2 Jon Schlueter 2016-10-05 02:25:53 UTC
openstack-tripleo-validations is included in OSP 10 beta

Comment 6 errata-xmlrpc 2016-12-14 15:52:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.