Bug 1368451 - [RFE] Implement multi threaded self-heal for ec volumes
Summary: [RFE] Implement multi threaded self-heal for ec volumes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1375465
TreeView+ depends on / blocked
 
Reported: 2016-08-19 12:52 UTC by Pranith Kumar K
Modified: 2017-03-27 18:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1375465 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:21:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-08-19 12:52:15 UTC
Description of problem:
We need a way to increase parallelism in number of heals that can happen in disperse volumes as well. This bug tracks that RFE

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-08-19 14:06:55 UTC
REVIEW: http://review.gluster.org/15083 (cluster/ec: Do multi-threaded self-heal) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Worker Ant 2016-08-24 17:21:08 UTC
REVIEW: http://review.gluster.org/15083 (cluster/ec: Do multi-threaded self-heal) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Worker Ant 2016-08-24 22:24:26 UTC
COMMIT: http://review.gluster.org/15083 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 56a79b357e09d91305994fcc0b2d250cb9ac243d
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Aug 4 00:41:16 2016 +0530

    cluster/ec: Do multi-threaded self-heal
    
    BUG: 1368451
    Change-Id: I5d6b91d714ad6906dc478a401e614115c89a8fbb
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/15083
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ashish Pandey <aspandey@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-27 18:21:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.