Bug 136846 - Changes to active devices in one profile take effect in ALL profiles
Changes to active devices in one profile take effect in ALL profiles
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 13:51 EDT by Rodolfo J. Paiz
Modified: 2009-07-14 12:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodolfo J. Paiz 2004-10-22 13:51:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Say you have eth0 and eth1. In profile "Home", you want eth0 active.
In profile "Work", you want eth1 active. However, if you select eth0
active and eth1 inactive for profile "Home" and then save the
settings, the *same* settings are stored for the "Work" profile as
well. This makes the whole concept of profiles entirely useless.

Version-Release number of selected component (if applicable):
system-config-network-1.3.22-1

How reproducible:
Always

Steps to Reproduce:
1. Create two profiles.
2. Set the devices you want active in one profile.
3. Save changes.
    

Actual Results:  Changes made to active devices in one profile are
incorrectly saved to ALL profiles.

Expected Results:  Changes should be made only to a single profile.

Additional info:

This has been broken for a couple of weeks now. I only managed to
report it now, but it's been here for a few revisions. However, it
used to work beautifully in FC1 which was what I ran before installing
FC3-T2.

I run an IBM Thinkpad T23 (2647-5NU) with an Intel e100 for eth0 and
an Intersil Prism (orinoco_pci) for eth1. Both work well, although
initially the Prism is incorrectly detected (see Bug #136188). System
is fully up-to-date, of course.

But listed as "high" severity since it causes major loss of
functionality for this program.
Comment 2 Rodolfo J. Paiz 2004-10-25 12:25:24 EDT
Harald, I read the instructions before I set it up, when trying to
figure out the problem, and again just now. This *is* a bug. Say you
want this:

Home: eth0 active,   eth1 inactive
Work: eth0 inactive, eth1 active

So first, you create the Work profile, copy eth0 to eth0_Work (or just
use eth0, doesn't matter), repeat for eth1, and set the devices you
wish to have active. Save changes.

Second, create the Home profile, configure as appropriate. Save changes.

Third, go back to the Work profile. You'll find that Work is now set
to "eth0 active, eth1 inactive" JUST LIKE HOME, and contrary to what
you configured earlier. The same devices are set active in all
profiles. Now fix your Work settings... and Home breaks since the Work
devices are also set active in the Home profile.

To troubleshoot this, I've even deleted all configurations from
system-config-network, deleted all hardware from /etc/sysconfig/hwconf
and /etc/modprobe.conf and redetected/reconfigured everything. Problem
persists.

Summary: Changes to active devices in one profile take effect in ALL
profiles.

Does this work for you? Because I've done things the same way using
this program for a while, and it worked before, and yes the
instructions have been followed to the letter, and it's broken now.

Comment 3 Rodolfo J. Paiz 2004-11-04 10:02:37 EST
Finally got it to work. In order to get proper functionality:

1. Must create other profiles AND leave the Common profile unused.
2. Must copy devices to other logical devices AND leave the base
("eth0") devices unused.

When using only other profiles to select and only other logical
devices, I am able to use the profiles and even select them at boot
with "netprofile=" on the kernel boot line. So I guess tecnnically it
works.

However, if I use the Common profile for anything, it breaks. If I use
eth0 or eth1 for anything, it breaks. Any settings made to those
propagate instantly and forcefully to the rest of the
profiles/devices. The documentation is NOT clear about these
limitations and restrictions, and in all honesty I consider this very
poor design. A good effort to solve a common problem, but not a good
result.

Close the bug as you will...
Comment 4 Matthew Miller 2006-07-10 16:14:30 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 5 Valent Turkovic 2007-05-25 11:38:24 EDT
I found this same exact bug in Fedora Core 6 and Fedora 7.

Please look  ath these two videos:
http://www.youtube.com/watch?v=Zoy9k5euZRQ
http://www.youtube.com/watch?v=oS8CfgGe7-Q
Comment 6 Otto Rey 2007-05-28 20:29:50 EDT
This is happening to me with Fedora 6 and Fedora 7  / Rawhide right now. Please,
change the bug priority to high.
Comment 8 Valent Turkovic 2007-05-30 05:12:12 EDT
Please view again videos.

We saw and read link you have us, and the conclusion is that the design is
flawed and not intuitive.
Comment 9 Rodolfo J. Paiz 2007-05-30 09:58:40 EDT
I'm afraid I have to agree here. This particular bit of design is not intuitive
at all. A better solution (from the user interface point of view) might be to
make copies of all network devices behind the scenes when a new profile is
created, then use the checkboxes to activate and configure "eth0" in whatever
profiles it's used.

Just as an example. 
Comment 10 Harald Hoyer 2007-05-30 12:13:54 EDT
agreed, bad design.. our fault... I am sorry.
Comment 11 Rodolfo J. Paiz 2007-05-30 15:51:05 EDT
Oh hey, don't be *sorry*... you people (guys and gals) do such phenomenal work
that I almost feel bad for criticizing any part of it! Still, I do so in the
spirit of making a tiny contribution, if only by providing feedback, to the
growth and development of Red Hat and Fedora. Solid loyal user for over a decade
now, and grateful as pie for what you all enable me to do.

I think you all should be proud that we can only find things like this to
nitpick about in such an awesome piece of software.
Comment 12 Valent Turkovic 2007-05-30 16:02:17 EDT
mee too :)

I completely agree and also feel bad when need to "criticize" any fedora devel
because you do marvelous work.
Comment 13 Valent Turkovic 2007-07-21 05:41:45 EDT
Harald are there any design changes in system-config-network being done for F8
regarding this "bug" ?
Comment 14 Valent Turkovic 2008-01-25 21:49:27 EST
is system-config-network being abandoned because of NetworkManager?
Comment 15 Harald Hoyer 2008-01-28 06:23:22 EST
no @ comment #14

not for F8 @ comment #13

you are free to join the development of s-c-network
https://fedorahosted.org/system-config-network
Comment 16 Valent Turkovic 2008-01-28 07:15:07 EST
I have zero programming skills :) You don't want me doing any coding :)
So this will just stay half broken and gradually be replaced with
NetworkManager, works for me :)
Comment 17 Bug Zapper 2008-05-13 21:58:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Bug Zapper 2009-06-09 17:59:43 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Valent Turkovic 2009-06-15 04:37:45 EDT
we all use NM so please close this bug.
Comment 20 Bug Zapper 2009-07-14 12:58:01 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.