Bug 1368548 - If node registration isn't complete (unsubscribed or no pool added) then inadequate fail/error message
Summary: If node registration isn't complete (unsubscribed or no pool added) then inad...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 17:18 UTC by William Henry
Modified: 2017-01-22 07:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:45:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description William Henry 2016-08-19 17:18:54 UTC
Description of problem:
Using the ansible script form github I tried installing Openshift on a master and a single node. The master was RHEL and registered with a pool attached. The node was registered but I forgot to attach a pool ID.

The ansible playbook ran but failed at:
/home/cloud-user/openshift-ansible/roles/openshift_version/tasks/set_version_containerized.yml

The version was set to 0.0 and v0.0 and therefore it couldn't be found. 

If the version is 0.0 and/or v0.0 then a message should remind the user to fully subscribe the node. Both register and add the appropriate pool.


Version-Release number of selected component (if applicable):

Latest on github.

How reproducible:
run: # ansible-playbook -vvvv /home/cloud-user/openshift-ansible/playbooks/byo/config.yml

On a cluster where one or more of the nodes in the cluster have not being full subscribed (unregistered or registered without a pool)


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Devan Goodwin 2016-08-23 21:28:17 UTC
Better error message added in https://github.com/openshift/openshift-ansible/pull/2348

Comment 3 Johnny Liu 2016-08-24 03:16:16 UTC
Verified this bug with openshift-ansible-3.3.14-1.git.0.ed5ec69.el7.noarch, and PASS.

1. create all necessary repos on master, only create rhel repo on node.
2. run ansible installation.
3. Failed with the following message:
TASK [openshift_version : fail] ************************************************
fatal: [10.14.6.219]: FAILED! => {"changed": false, "failed": true, "msg": "No OpenShift version available, please ensure your systems are fully registered and have access to appropriate yum repositories."}

Comment 5 errata-xmlrpc 2016-09-27 09:45:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.