Bug 1368557 - dnsrecord-add does not prompt for missing record parts internactively
Summary: dnsrecord-add does not prompt for missing record parts internactively
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-19 18:17 UTC by Petr Vobornik
Modified: 2016-11-04 06:01 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:01:44 UTC


Attachments (Terms of Use)
evidence (271 bytes, text/plain)
2016-09-15 08:51 UTC, Pavel Picka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-08-19 18:17:53 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6203

This is how dnsrecord-add behaves in 4.4:
{{{
$ ipa dnsrecord-add example.test test --srv-target $HOSTNAME
ipa: ERROR: invalid 'srvrecord': 'srv_priority' is a required part of DNS record
}}}

This is how it behaved before 4.4:
{{{
$ ipa dnsrecord-add example.test test --srv-target $HOSTNAME
SRV Priority: 
...
}}}

Comment 1 Petr Vobornik 2016-09-05 15:53:13 UTC
Marking as regression - in 7.2 the interactive prompt worked.

Comment 5 Pavel Picka 2016-09-15 08:51 UTC
Created attachment 1201161 [details]
evidence

verified 
4.4.0-11

Comment 7 errata-xmlrpc 2016-11-04 06:01:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.