Bug 136868 - AMI MegaRAID worked under FC2, but not FC3 test3
AMI MegaRAID worked under FC2, but not FC3 test3
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-10-22 15:27 EDT by Pete Gale
Modified: 2015-01-04 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 20:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pete Gale 2004-10-22 15:27:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
Under FC1 and FC2, the MegaRAID module worked for my American
Megatrends card. Under FC3, it just won't load the devices. I'm not
sure if it's a kernel or udev problem.

Here is what `lspci -vv` yields for this card:

00:0b.0 RAID bus controller: American Megatrends Inc. MegaRAID (rev 02)
        Subsystem: American Megatrends Inc. MegaRAID 475 Express
500/500LC RAID Controller
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 32, Cache Line Size 08
        Interrupt: pin A routed to IRQ 137
        Region 0: Memory at d7000000 (32-bit, prefetchable) [size=64K]
        Capabilities: [80] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Version-Release number of selected component (if applicable):
kernel-smp-2.6.8-1.541, kernel-smp-2.6.9-1.640

How reproducible:

Steps to Reproduce:
1. Get a working FC2 system with an AMI MegaRAID 475 card.
2. Upgrade to FC3.
3. Despair.

Additional info:
Comment 1 Bill Nottingham 2004-10-22 21:09:14 EDT
What happens when the module is loaded?
Comment 2 Brian Lusk 2004-10-25 08:54:21 EDT
Possibly closely related to

I had much the same happen to me, except it wouldn't even show the
devices in installation.  Have you checked to make sure you are at the
latest firmware level?  My card wouldn't update, but yours might.
Comment 3 Pete Gale 2004-10-26 15:54:58 EDT
Bill - Even if I manually load megaraid_mm/megaraid_mbox, I don't see
the array. It used to show up as sdc. (I also have an Adaptec card
with 2 drives attached to it.) Did something change with the kernel,
or is this an udev problem? It used to work with the old kernel/devfs

Brian - My card isn't listed on the Manufacturer's site anymore. Given
it's excellent history, I am less likely to believe it is a firmware
problem with the card than a problem introduced by kernel/udev/devfs
changes in FC3.
Comment 4 Brian Lusk 2004-10-26 19:19:42 EDT
Pete - OK, just thought I'd check.  I show the MegaRAID 475 to be the
direct transfer to the LSI Logic MegaRAID Express 500.  (LSI bought
all of AMI's RAID card business, as far as I can tell).  Here's the
downloads page for that card, but you'll be able to narrow down
whether or not it is the same card far better than I.


Good luck!  I think whatever fixes your problems will likely fix mine,

Comment 5 Pete Gale 2004-10-27 03:46:26 EDT
Brian - Thanks for the link. It looks like it's for my card, but I got
nervous while going through the readme.txt. The part about "MAKE SURE
updating. Color me cautious on flashing my BIOS. =/
Comment 6 Pete Gale 2004-10-29 04:06:20 EDT
After a little more digging, I think it's a udev problem. `lspci -vv`
lists that the card is at address 00:0b.0 on the PCI bus. udevinfo for
this device reveals this:

# udevinfo -a -p /sys/devices/pci0000\:00/0000\:00\:0b.0/

udevinfo starts with the device the node belongs to and then walks up the
device chain, to print for every device found, all possibly useful
in the udev key format.
Only attributes within one device section may be used together in one
to match the device for which the node will be created.

  looking at class device '/sys/devices/pci0000:00/0000:00:0b.0':

It looks like the card is attached and responding, but the system
doesn't know what to do with it. I'm just starting to learn about
udev, however, so I may be completely off-base.
Comment 7 Dave Mull 2004-11-09 17:40:31 EST
Upgrading the firmware to the latest version does not resolve this
issue. The driver used for FC3 will not recognise any partitions on
the MegaRAID Express 500 controller - regardless of firmware.
Amazingly this  made it out of test into the released version this week.

I have yet to find a way to get the correct megaraid driver to load
sinc e obviously the one included is defective and the old driver was
excluded from the FC3 installer.
Comment 8 Pete Gale 2004-11-15 03:49:51 EST
I just upgraded to the full FC3 (from FC3-test2) and applied all of
the released updates. Still no dice. Upgrading the kernel also gave
warnings about no modules for megaraid or megaraid2. Has anyone had
any luck with this?
Comment 9 Dave Jones 2005-07-15 15:44:01 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Dave Jones 2005-10-02 20:25:21 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.