Bug 1368754 - ipa server uninstall fails with Python "Global Name error"
Summary: ipa server uninstall fails with Python "Global Name error"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1366991
TreeView+ depends on / blocked
 
Reported: 2016-08-21 05:17 UTC by Abhijeet Kasurde
Modified: 2016-11-04 06:01 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:01:49 UTC


Attachments (Terms of Use)
ipa-server-uninstall.log (14.35 KB, text/plain)
2016-08-21 05:18 UTC, Abhijeet Kasurde
no flags Details
console.log (1.04 KB, text/plain)
2016-09-06 09:57 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-08-21 05:17:59 UTC
Description of problem:
While performing http://www.freeipa.org/page/V4/Manage_replication_topology_4_4/Test_Plan#Test_case:_ipa_server-del_command

following error message is encountered on second replica 

[root@hp-sl2x170zg6-02 ~]# ipa-server-install --uninstall -U
ipa         : ERROR    global name 'ScriptError' is not defined


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Perform steps mentioned in FreeIPA Manage Replica Topology 4.4 Test plan related to "server_del API call is executed at ipa-server-install --uninstall on the replica under domain level 1"

Actual results:
Python Global name error is shown

Expected results:
server uninstall should succes


Additional info:
Following change is required 

[root@hp-sl2x170zg6-02 ~]# diff /usr/lib/python2.7/site-packages/ipaserver/install/server/install.py /tmp/install.py
19d18
< from ipapython.admintool import ScriptError

Comment 1 Abhijeet Kasurde 2016-08-21 05:18 UTC
Created attachment 1192538 [details]
ipa-server-uninstall.log

Comment 3 Petr Vobornik 2016-08-22 07:35:23 UTC
A rebase issue where fea56fefff48b0d8eb147c2c2c511c869a1eadf0 depends on import introduced in  5776f1e90000ccfc24689c99951864248ed01045 but the latter was not backported. Backport of the former should contain the ScriptError import

Comment 4 Petr Vobornik 2016-08-24 16:11:34 UTC
Putting to POST to indicate that no new patch is needed, but the one in comment 3 needs to be properly backported.

Comment 7 Abhijeet Kasurde 2016-09-06 09:57 UTC
Created attachment 1198155 [details]
console.log

Verified using IPA version ::
ipa-server-4.4.0-9.el7.x86_64


Marking BZ as verified.

Comment 9 errata-xmlrpc 2016-11-04 06:01:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.