Bug 1368800 - ETPS/2 Elantech Touchpad detected as mouse
Summary: ETPS/2 Elantech Touchpad detected as mouse
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-21 13:22 UTC by Stephen Finucane
Modified: 2016-09-01 15:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-01 15:27:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephen Finucane 2016-08-21 13:22:07 UTC
Description of problem:

I'm trying to get natural scrolling enabled on a Samsung Series 9 15" notebook. The notebook uses an Elantech touchpad, identified as "ETPS/2", and is running Fedora 24 with Gnome on Wayland.

There was no touchpad configuration options available in gnome-control-center, so it was necessary to create a configuration file:

    $ cat /etc/X11/xorg.conf.d/30-touchpad.conf
    Section "InputClass"
            Identifier "libinput pointer catchall"
            MatchIsPointer "on"
            MatchDevicePath "/dev/input/event*"
            Driver "libinput"
            Option "NaturalScrolling" "true"
    EndSection

    Section "InputClass"
            Identifier "libinput touchpad catchall"
            MatchIsTouchpad "on"
            MatchDevicePath "/dev/input/event*"
            Driver "libinput"
            Option "NaturalScrolling" "true"
    EndSection

After this, the option to enable/disable natural scrolling appeared in gnome-control-center.

I don't imagine it should have been necessary to create this file to enable this functionality. This device is still registering itself as a pointer device (a pseudonym for a mouse?), when I think it should be registering as a touchpad. I've included additional output from xinput and libinput utilities.

Version-Release number of selected component (if applicable):

* Fedora 24 (4.6.6-300.fc24.x86_64)
* libinput 1.4.1
* Gnome 3.20

How reproducible:

Always

Steps to Reproduce:
1. Open 'gnome-control-center'
2. Click "Mouse & touchpad"

Actual results:

There should be options to configure natural scrolling and other touchpad features.

Expected results:

The only option is to switch left and right click.

Additional info:

$ xinput 
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Webcam SC-13HDL11624N                   	id=9	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=10	[slave  keyboard (3)]
$ xinput list-props "ETPS/2 Elantech Touchpad"
Device 'ETPS/2 Elantech Touchpad':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (272):	0
	libinput Tapping Enabled Default (273):	0
	libinput Tapping Drag Enabled (274):	1
	libinput Tapping Drag Enabled Default (275):	1
	libinput Tapping Drag Lock Enabled (276):	0
	libinput Tapping Drag Lock Enabled Default (277):	0
	libinput Accel Speed (278):	0.000000
	libinput Accel Speed Default (279):	0.000000
	libinput Natural Scrolling Enabled (280):	1
	libinput Natural Scrolling Enabled Default (281):	0
	libinput Send Events Modes Available (256):	1, 1
	libinput Send Events Mode Enabled (257):	0, 0
	libinput Send Events Mode Enabled Default (258):	0, 0
	libinput Left Handed Enabled (282):	0
	libinput Left Handed Enabled Default (283):	0
	libinput Scroll Methods Available (284):	1, 1, 0
	libinput Scroll Method Enabled (285):	1, 0, 0
	libinput Scroll Method Enabled Default (286):	1, 0, 0
	libinput Click Methods Available (287):	1, 1
	libinput Click Method Enabled (288):	1, 0
	libinput Click Method Enabled Default (289):	1, 0
	libinput Middle Emulation Enabled (290):	0
	libinput Middle Emulation Enabled Default (291):	0
	libinput Disable While Typing Enabled (292):	1
	libinput Disable While Typing Enabled Default (293):	1
	Device Node (259):	"/dev/input/event5"
	Device Product ID (260):	2, 14
	libinput Drag Lock Buttons (294):	<no items>
	libinput Horizonal Scroll Enabled (261):	1
$ sudo libinput-list-devices
...
Device:           ETPS/2 Elantech Touchpad
Kernel:           /dev/input/event5
Group:            6
Seat:             seat0, default
Size:             105.16x73.61mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Comment 1 Peter Hutterer 2016-08-22 02:07:08 UTC
what happens if you remove the Driver "libinput" line from your snippet? I suspect that what possibly happens here is that some other snippet assigns the synaptics driver which isn't supported by the control center anymore.

do you by any chance have xorg-x11-drv-libinput-0.19.0-1 installed? if so, update to -2 please.

Comment 2 Ray Strode [halfline] 2016-08-22 14:20:41 UTC
do you have cinnamon installed? I think it installs some override to force synaptics over libinput.

Comment 3 Stephen Finucane 2016-08-22 14:34:14 UTC
(In reply to Peter Hutterer from comment #1)
> what happens if you remove the Driver "libinput" line from your snippet? I
> suspect that what possibly happens here is that some other snippet assigns
> the synaptics driver which isn't supported by the control center anymore.
> 
> do you by any chance have xorg-x11-drv-libinput-0.19.0-1 installed? if so,
> update to -2 please.

I removed that snippet and rebooted. The output of 'xinput', 'xinput list-props' and 'libinput-list-devices' remains the same.

I am using -2 already

(In reply to Ray Strode [halfline] from comment #2)
> do you have cinnamon installed? I think it installs some override to force
> synaptics over libinput.

I do have the Cinnamon spin installed, yes, and sorry for not including that in the original bug report. However, I have since installed Gnome, configured gdm, and removed any Cinnamon or lightdm-related package I could find. It's pretty much the standard Workstation (?) release now.

Comment 4 Ray Strode [halfline] 2016-08-22 14:48:49 UTC
do "dnf remove xorg-x11-drv-synaptics" fix it?

Comment 5 Stephen Finucane 2016-08-22 14:54:38 UTC
(In reply to Ray Strode [halfline] from comment #4)
> do "dnf remove xorg-x11-drv-synaptics" fix it?

After removing the xorg-x11-drv-synaptics package and the '30-touchpad.conf' file, it seems the options appear in gnome-control-center as expected. Good stuff :) The device is still listed as having only 'pointer' capability via 'libinput-list-devices' though. Is this expected?

Comment 6 Peter Hutterer 2016-08-24 08:51:18 UTC
(In reply to Stephen Finucane from comment #5)
> The device is still listed as having only 'pointer' capability via
> libinput-list-devices' though. Is this expected?

yep, touchpads don't have their own capability since they're just pointer devices.

Comment 7 Stephen Finucane 2016-09-01 15:27:59 UTC
(In reply to Peter Hutterer from comment #6)
> (In reply to Stephen Finucane from comment #5)
> > The device is still listed as having only 'pointer' capability via
> > libinput-list-devices' though. Is this expected?
> 
> yep, touchpads don't have their own capability since they're just pointer
> devices.

Perfect, then we can close this bug. Thank you for the help.


Note You need to log in before you can comment on or make changes to this bug.