Bug 1368913 - Openshift master major version info messed up
Summary: Openshift master major version info messed up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-22 05:37 UTC by Xia Zhao
Modified: 2016-09-27 09:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:45:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Xia Zhao 2016-08-22 05:37:34 UTC
Description of problem:
Install OSE latest puddle (v3.3.0.23), after it completes successfully, got extra string "dirty" in command "openshift version":
# openshift version
openshift v3.3.0.23-dirty
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Version-Release number of selected component (if applicable):
openshift v3.3.0.23-dirty
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1.Install OSE with the latest puddle (v3.3.0.23)

Actual results:
# openshift version
openshift v3.3.0.23-dirty
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Expected results:
# openshift version
openshift v3.3.0.23
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Additional info:
1. Repro on both openstack and AWS
2. Not repro with last puddle v3.3.0.22

Comment 1 Juan Vallejo 2016-08-23 20:32:09 UTC
Closing this as not a bug. See conversation in this thread:
https://github.com/openshift/origin/pull/10602#issuecomment-241857909

Comment 2 Juan Vallejo 2016-08-23 20:35:47 UTC
> Closing this as not a bug. See conversation in this thread:
> https://github.com/openshift/origin/pull/10602#issuecomment-241857909

The reason why "dirty" shows up in version information is because the openshift build is leaving the working directory in a dirty state.

Re-assigning to mkargaki@redhat.com to get his thoughts on this before closing.

https://github.com/openshift/origin/pull/10602#issuecomment-241857909

Comment 3 Michail Kargakis 2016-08-24 08:42:43 UTC
https://github.com/openshift/origin/pull/10602#issuecomment-241858026 should be addressed. I am not sure who is responsible for the build process of the repo. Probably Clayton?

Comment 4 Troy Dawson 2016-09-01 15:38:36 UTC
This was an OSE bug, not openshift origin.  It has been fixed in OSE v3.3.0.28 or newer.
We have also pushed the fix upstream in this pull request.
https://github.com/openshift/origin/pull/10666

But marking this onto QE so that the OSE issue can be verified and closed.

Comment 8 errata-xmlrpc 2016-09-27 09:45:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.