Bug 1368918 - tests/bugs/cli/bug-1320388.t: Infrequent failures
Summary: tests/bugs/cli/bug-1320388.t: Infrequent failures
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1368349 1368926
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-22 06:23 UTC by Ashish Pandey
Modified: 2016-09-16 18:27 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1368349
Environment:
Last Closed: 2016-09-16 18:27:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ashish Pandey 2016-08-22 06:23:58 UTC
+++ This bug was initially created as a clone of Bug #1368349 +++

The bug-1320388.t test has been failing on slave24 and slave27 builders causing all recent regression jobs [1][2] to fail on these machines.

The failure is happening because the test is attempting to enable management encryption without having valid certificates (/etc/ssl/glusterfs.{ca,key,pem}). In slave24 these files are not present (possibly because of re-imaging) and in slave27 these certificates are expired, as the machine was down for 2 months.

The test depended on these certificates being generated by another test, features/ssl-authz.t, in a previous run. But this ssl-authz is run after bug-1320388.t, so valid certificates weren't present on slave24 and slave27.

The test needs to ensure that it generates certificates on its own before enabling management encryption to avoid this failure.

[1] https://build.gluster.org/computer/slave24.cloud.gluster.org/builds
[2] https://build.gluster.org/computer/slave27.cloud.gluster.org/builds

--- Additional comment from Vijay Bellur on 2016-08-19 04:50:02 EDT ---

REVIEW: http://review.gluster.org/15202 (tests/cli: Generate SSL certificates) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-08-22 00:03:47 EDT ---

COMMIT: http://review.gluster.org/15202 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit fad93c16a3fc52171f3f2b024baa5bc8b8749bee
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Fri Aug 19 14:13:51 2016 +0530

    tests/cli: Generate SSL certificates
    
    Generate SSL certificates before enabling
    management encryption to avoid test failure.
    
    Change-Id: Iab23b36703f4653f1d5bb9d14695e4d3fa63ad61
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    BUG: 1368349
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/15202
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Worker Ant 2016-08-22 07:11:02 UTC
REVIEW: http://review.gluster.org/15228 (tests/cli: Generate SSL certificates) posted (#1) for review on release-3.8 by Ashish Pandey (aspandey@redhat.com)

Comment 2 Worker Ant 2016-08-26 10:12:58 UTC
REVIEW: http://review.gluster.org/15228 (tests/cli: Generate SSL certificates) posted (#2) for review on release-3.8 by Ashish Pandey (aspandey@redhat.com)

Comment 3 Worker Ant 2016-09-06 09:07:18 UTC
REVIEW: http://review.gluster.org/15228 (tests/cli: Generate SSL certificates) posted (#3) for review on release-3.8 by Ashish Pandey (aspandey@redhat.com)

Comment 4 Worker Ant 2016-09-06 14:54:30 UTC
REVIEW: http://review.gluster.org/15228 (tests/cli: Generate SSL certificates) posted (#4) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)

Comment 5 Worker Ant 2016-09-07 14:55:09 UTC
COMMIT: http://review.gluster.org/15228 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 097b4b0ed1267015df82c89dcd1aaffeef02dba5
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Fri Aug 19 14:13:51 2016 +0530

    tests/cli: Generate SSL certificates
    
    Generate SSL certificates before enabling
    management encryption to avoid test failure.
    
    master -
    This patch is backport of following two master patches
    
    http://review.gluster.org/#/c/13959/ - bug-1320388.t
    was first introduced in this patch
    
    http://review.gluster.org/#/c/15202/ - Modified
    bug-1320388.t to create SSL cerificate
    
    >Change-Id: Iab23b36703f4653f1d5bb9d14695e4d3fa63ad61
    >Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    >BUG: 1368349
    >Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    >Reviewed-on: http://review.gluster.org/15202
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    
    Change-Id: Iab23b36703f4653f1d5bb9d14695e4d3fa63ad61
    BUG: 1368918
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/15228
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 6 Niels de Vos 2016-09-12 05:37:53 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 7 Niels de Vos 2016-09-16 18:27:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.4, please open a new bug report.

glusterfs-3.8.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-September/000060.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.