Bug 1368947 - Please update openshift_examples files
Summary: Please update openshift_examples files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-22 08:28 UTC by Zhang Cheng
Modified: 2016-09-19 13:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 13:27:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Zhang Cheng 2016-08-22 08:28:09 UTC
[Installer] Should update openshift_examples files
M
M

Description of problem: Please update openshift_examples files

How reproducible:
Always

Steps to Reproduce:
There are some openshift examples files created while installing need to be updated.
such as: 
https://github.com/openshift/openshift-ansible/tree/master/roles/openshift_examples/files/examples/v1.3/infrastructure-templates/enterprise/metrics-deployer.yaml, it should be updated base on https://github.com/openshift/origin-metrics/blame/enterprise/metrics.yaml

https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_examples/files/examples/v1.3/infrastructure-templates/origin/metrics-deployer.yaml, it should be updated base on https://github.com/openshift/origin-metrics/blob/master/metrics.yaml

# diff metrics-deployer.yaml metrics.yaml
36a37
>     securityContext: {}
39a41
>       securityContext: {}
50a53,56
>         - name: POD_NAME
>           valueFrom:
>             fieldRef:
>               fieldPath: metadata.name
60a67,68
>         - name: IGNORE_PREFLIGHT
>           value: ${IGNORE_PREFLIGHT}
62a71,72
>         - name: DYNAMICALLY_PROVISION_STORAGE
>           value: ${DYNAMICALLY_PROVISION_STORAGE}
70a81,84
>         - name: USER_WRITE_ACCESS
>           value: ${USER_WRITE_ACCESS}
>         - name: HEAPSTER_NODE_ID
>           value: ${HEAPSTER_NODE_ID}
86c100
<   value: "registry.access.redhat.com/openshift3/"
---
>   value: "openshift/origin-"
90c104
<   value: "3.2.1"
---
>   value: "latest"
100c114
<   description: "Can be set to: 'deploy' to perform an initial deployment; 'refresh' to delete and redeploy all components but to keep persisted data and routes; 'redeploy' to delete and redeploy everything (losing all data in the process)"
---
>   description: "Can be set to: 'preflight' to perform validation before a deployment; 'deploy' to perform an initial deployment; 'refresh' to delete and redeploy all components but to keep persisted data and routes; 'redeploy' to delete and redeploy everything (losing all data in the process); 'validate' to re-run validations after a deployment"
107a122,125
>   description: "If preflight validation is blocking deployment and you're sure you don't care about it, this will ignore the results and proceed to deploy."
>   name: IGNORE_PREFLIGHT
>   value: "false"
> -
111a130,133
>   description: "Set to true to dynamically provision storage, set to false to use use pre-created persistent volumes"
>   name: DYNAMICALLY_PROVISION_STORAGE
>   value: "false"
> -
124c146,154
<   description: "How often metrics should be gathered. Defaults value of '10s' for 10 seconds"
---
>   description: "If a user accounts should be allowed to write metrics."
>   name: USER_WRITE_ACCESS
>   value: "false"
> -
>   description: "The identifier used when generating metric ids in Hawkular"
>   name: HEAPSTER_NODE_ID
>   value: "nodename"
> -
>   description: "How often metrics should be gathered. Defaults value of '15s' for 15 seconds"
126c156
<   value: "10s"
---
>   value: "15s"

addition info: 
1. It is better if you can double check all the examples files and to see if we need to update by
https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_examples/examples-sync.sh

Comment 1 Scott Dodson 2016-08-22 20:02:04 UTC
This is included in https://github.com/openshift/openshift-ansible/pull/2052 (not yet merged)

Comment 4 Scott Dodson 2016-09-19 13:27:16 UTC
Not a bug in released product, closing.


Note You need to log in before you can comment on or make changes to this bug.