Bug 136911 - [ia64] OpenOffice fails to launch
[ia64] OpenOffice fails to launch
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 20:28 EDT by Chris Lee
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 07:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lee 2004-10-22 20:28:39 EDT
User-Agent:       
Build Identifier: 

When I click on any of the OpenOffice.org links on the default menu in Rawhide,
OpenOffice.org fails to launch.

The following message is in the file ~/.openoffice-install-log:

Installation of OpenOffice.org 1.1.2 failed:
'LD_LIBRARY_PATH=/usr/lib/ooo-1.1:/usr/lib/ooo-1.1/program
/usr/lib/ooo-1.1/program/setup -R:/tmp/ooo-wrapper.autoresponse.file.K13037 -v
-nogui > ~/.openoffice-install-log 2>&1'

Which seems to be caused by the fact that there *is* no 'setup' binary in
/usr/lib/ooo-1.1/program - it lives in /emul/ia32-linux/usr/lib/ooo-1.1/program
instead.

Reproducible: Always
Steps to Reproduce:
1. Log into GNOME.
2. Click on any OpenOffice.org icon on the panel.
3. Watch it not launch.
Actual Results:  
Nothing.

Expected Results:  
OpenOffice.org should have launched properly. Failing that, some notification
that it was not going to launch should have been provided.
Comment 1 Chris Lee 2004-10-22 20:30:17 EDT
Please note that this is IA64-specific. Updating severity (new bugzilla doesn't
like me setting the severity in the initial report)
Comment 2 Bill Nottingham 2004-10-22 21:24:52 EDT
i386 openoffice doesn't work on ia64; it breaks with the path
translation. Perhaps we should exclude it.
Comment 3 Dan Williams 2004-10-23 20:25:37 EDT
I assume this would be fixed by an install scripts fix, but OOo
_really_ expects to be installed in a specific place and doesn't like
not being there.

Bill:  it should be a simple fix to the launcher script to get it to
work, but how do I know where the ia32 root is?  Is there some magic
environment variable that I can check to figure out what to prepend to
the path to the setup program?
Comment 4 Chris Lee 2004-10-25 14:05:50 EDT
Adding blocker for the GNOME-broken-IA64-issues bug.
Comment 5 Bill Nottingham 2004-10-25 15:15:12 EDT
On ia64, the install prefix is /emul/ia32-linux. *However*,
if you run the installer script in a 32-bit shell, things should just
work. Of course, doing that is tricky.
Comment 6 Chris Lee 2004-10-25 15:22:33 EDT
Removing this from the blocker list, per notting's request
Comment 7 Lawrence Lim 2004-10-28 23:53:47 EDT
Bug 137395 has the same problem as well but it was filed under x86_64
arch.
Comment 8 Caolan McNamara 2005-04-04 10:29:20 EDT
Seeing as rh#137395# is fixed and close, does this work on ia64 as well since
that version ?
Comment 9 Caolan McNamara 2005-04-13 07:57:09 EDT
no response -> assuming its ok on ia64 as the very similiar x86_64 bug is long
time closed.

Note You need to log in before you can comment on or make changes to this bug.