This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136926 - misconfigured x server causes infinite loop during early boot
misconfigured x server causes infinite loop during early boot
Status: CLOSED DUPLICATE of bug 135574
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 06:18 EDT by Adam Wiggins
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Wiggins 2004-10-23 06:18:03 EDT
After upgrading my kernel to the latest rawhide (2.6.9) last night, rebooting caused the 
system to lock at the "Configuring kernel parameters..." message that appears as the third 
or fourth line from the beginning of the boot process.  The system was not hard locked (I 
could press enter and the cursor went to the next line), but it sat their indefinitely.  Going 
into single user mode and then immediately exiting allowed a normal boot.

I eventually figured out that my X server was failing to launch, because I had my video 
driver set to "nv" (nvidia's proprietary 3d drivers) but had not yet recompiled the driver to 
work with the new kernel  This stage of the boot process is when it tries to launch into 
graphical mode.  Therefore, using single user mode (which does not use graphical boot) or 
turning off graphical boot explicitly.

I believe that the boot process should recover from failing to launch the X server by falling 
back to standard text mode boot.  Some users would not think to try single-user mode 
and would presume that their system was unbootable and required an OS wipe.
Comment 1 Bill Nottingham 2004-10-25 15:30:46 EDT
This appears to be a failing of the nVidia drivers... they really
shouldn't *hang*, they should just fail to initialize.

Assigning to rhgb in case it's hanging on X failure to start.
Comment 2 Daniel Veillard 2004-11-19 11:41:41 EST

*** This bug has been marked as a duplicate of 135574 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.