This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 136928 - gthumb-import with usb-storage camera _almost_ works perfectly.
gthumb-import with usb-storage camera _almost_ works perfectly.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 07:18 EDT by Pekka Pietikäinen
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-01 11:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hald log after camera is plugged in (33.92 KB, text/plain)
2004-10-23 07:19 EDT, Pekka Pietikäinen
no flags Details

  None (edit)
Description Pekka Pietikäinen 2004-10-23 07:18:45 EDT
Description of problem:

When plugging in my Nikon Coolpix 995 camera and using gthumb-import
%h as the import thing I get two "There are new pictures" dialogs, one
for 

/org/freedesktop/Hal/devices/usb_device_4b0_104_100_-1_000004006811
and the other for
/org/freedesktop/Hal/devices/block_8_65

The first one fails since the thing is used by usb-storage and it tries
gthumb --import-photos, the second one works just as I want it to.

So close to working perfectly that it's almost annoying 
(I didn't have high hopes for this stuff initially :-) )

I've attached a hald debug log in case that helps.

gnome-volume-manager-1.1.0-5
hal-0.4.0-5
gthumb-2.4.2-2

Would be nice to get working some time after FC3 ;)
Comment 1 Pekka Pietikäinen 2004-10-23 07:19:26 EDT
Created attachment 105688 [details]
hald log after camera is plugged in
Comment 2 John (J5) Palmieri 2004-10-25 10:29:44 EDT
The quick fix is to edit /etc/hotplug/usb.usermap and take out the
line for your camera.  Eventually these will all be changed into FDI
files so we have finer control on how they are detected.
Comment 3 John (J5) Palmieri 2004-12-06 13:44:08 EST
David, is this fixed yet?
Comment 4 Matthias Clasen 2007-04-01 10:49:03 EDT
Putting this in NEEDINFO. Does this still cause problems ?
Comment 5 Pekka Pietikäinen 2007-04-01 11:29:14 EDT
Hmm. Don't remember seeing this problem for the last year or so. Don't have the
camera with me currently, so 100% double-checking isn't possible. Closing in any
case and I'll reopen if it still misbehaves.

Note You need to log in before you can comment on or make changes to this bug.