Bug 136930 - [FC3] [PATCH] patch for hiding modems doesn't support > 1 soundcard
Summary: [FC3] [PATCH] patch for hiding modems doesn't support > 1 soundcard
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-10-23 12:29 UTC by Ronald Bultje
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: gnome-media-2.8.0-3.FC3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 19:54:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ronald Bultje 2004-10-23 12:29:43 UTC
gnome-media-2.8.0-gst-mixer-nomodem.patch in gnome-media 2.8.0-3 is
broken. It doesn't reset the element state if it found no tracks, and
thus therefore the next device in the list will not actually open
(since open is done between NULL and READY) and thus the next device
will not show up in the list.

+      if (!page)
+       continue;

Should change to:

+      if (!page) {
+        gst_element_set_state (element, GST_STATE_NULL);
+        continue;
+      }

Comment 1 Colin Walters 2004-10-25 20:43:33 UTC
Ok I built this fix into rawhide, trying to see if I can get it in FC3.

Comment 2 Colin Walters 2004-11-08 19:54:53 UTC
Pushed as FC3 update.


Note You need to log in before you can comment on or make changes to this bug.