Bug 1369392 - package not listed in project page
Summary: package not listed in project page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Copr
Classification: Community
Component: frontend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-23 09:35 UTC by Vasiliy G Tolstov
Modified: 2016-10-09 02:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-12 17:05:05 UTC


Attachments (Terms of Use)

Description Vasiliy G Tolstov 2016-08-23 09:35:39 UTC
Description of problem:
I'm import from git some packages to atomic project, but no one listed on page

Version-Release number of selected component (if applicable):


How reproducible:
Create package from git repo
Package created but not listed

Steps to Reproduce:
1. go to packages in project
2. create package specify name, git repo and click on create
3. package created but not listed

Actual results:
package list is empty

Expected results:
see newly created package

Additional info:

Comment 1 Vasiliy G Tolstov 2016-08-23 11:53:29 UTC
What info i need to provide to speedup resolving this issue?

Comment 2 clime 2016-08-23 15:15:33 UTC
Packages with no builds yet are not currently displayed in the package table but they should appear after you build them for the first time. It's not a serious issue I would say for quick/hot fixing to be required but it is still a bug to be fixed.

Comment 3 Vasiliy G Tolstov 2016-08-23 15:19:28 UTC
But how can i build package that not listed? In builds i can create new build, but page again need to enter srpm or something else.
But i'm already have spec file...

Comment 4 Vasiliy G Tolstov 2016-08-24 09:49:22 UTC
???

Comment 5 clime 2016-08-26 01:17:26 UTC
Fixed by https://github.com/fedora-copr/copr/commit/424ddd80.

Comment 6 clime 2016-08-26 01:26:59 UTC
(In reply to Vasiliy G Tolstov from comment #3)
> But how can i build package that not listed? In builds i can create new
> build, but page again need to enter srpm or something else.
> But i'm already have spec file...

You can submit a build that generates the package and it will be automatically associated with the package based on name comparison (COPR package name and the name part of the srpm filename are compared). 

Or better, you can use copr-cli command line tool to be able to build the package directly from its definition. There is a command copr-cli build-package --name <pkgname> <projectname> that you can use.

Comment 7 Vasiliy G Tolstov 2016-08-26 10:22:11 UTC
 copr-cli build-package
usage: copr [-h] [--debug] [--config CONFIG]
            {list,create,modify,delete,build,buildpypi,buildgem,buildtito,buildmock,status,download-build,cancel,watch-build,add-package-tito,edit-package-tito,add-package-pypi,edit-package-pypi,add-package-mockscm,edit-package-mockscm,add-package-upload,edit-package-upload,add-package-urls,edit-package-urls,add-package-rubygems,edit-package-rubygems,list-packages,get-package,delete-package,reset-package}


I don't have build-package subcommand

Comment 8 Vasiliy G Tolstov 2016-08-26 10:24:29 UTC
copr-cli buildmock --scm-url https://github.com/vtolstov/fedora-vtolstov.git --spec ostree/ostree.spec atomic

can't import package because it does not go to subdir when search for sources

Comment 9 Vasiliy G Tolstov 2016-08-26 11:53:16 UTC
hm i think that i need repo per package...

Comment 10 Vasiliy G Tolstov 2016-08-26 12:13:03 UTC
via cli i'm able to add package and build. but issue is present - before i can ran first build, in packages i dont see anything.

Comment 11 clime 2016-09-01 11:50:10 UTC
It will take time to get the fix into production so that it _actually_ works as expected.

Comment 12 Vasiliy G Tolstov 2016-09-01 11:53:48 UTC
Thanks!

Comment 13 Fedora Update System 2016-09-12 06:25:03 UTC
copr-frontend-1.101-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-acf014bf51

Comment 14 Fedora Update System 2016-09-12 06:25:10 UTC
copr-frontend-1.101-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a3cdc5801

Comment 15 Fedora Update System 2016-09-12 06:26:04 UTC
copr-frontend-1.101-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b1155f62d6

Comment 16 clime 2016-09-12 06:41:51 UTC
New copr-frontend version has been released.

Comment 17 Vasiliy G Tolstov 2016-09-12 10:04:48 UTC
Thanks

Comment 18 Fedora Update System 2016-09-12 14:50:41 UTC
copr-frontend-1.101-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a3cdc5801

Comment 19 Fedora Update System 2016-09-12 15:26:49 UTC
copr-frontend-1.101-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b1155f62d6

Comment 20 Fedora Update System 2016-09-12 15:27:01 UTC
copr-frontend-1.101-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-acf014bf51

Comment 21 Vasiliy G Tolstov 2016-09-12 16:18:43 UTC
I don't have copr-frontend installed =). Does it deployed already on copr.fedorainfracloud.org?

Comment 22 clime 2016-09-12 17:05:05 UTC
(In reply to Vasiliy G Tolstov from comment #21)
> I don't have copr-frontend installed =). Does it deployed already on
> copr.fedorainfracloud.org?

Yes :).

Comment 23 Fedora Update System 2016-10-03 17:22:56 UTC
copr-frontend-1.101-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2016-10-03 20:20:50 UTC
copr-frontend-1.101-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2016-10-09 02:55:49 UTC
copr-frontend-1.101-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.