Bug 1369403 - [RFE]: events from protocol server
Summary: [RFE]: events from protocol server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard: USM-Gluster integration
: 1369402 (view as bug list)
Depends On: 1367382
Blocks: 1373740
TreeView+ depends on / blocked
 
Reported: 2016-08-23 10:20 UTC by Prasanna Kumar Kalever
Modified: 2017-03-06 17:22 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1367382
: 1373740 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:22:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-08-23 10:20:09 UTC
Description of problem:
This RFE is to track the changes required in the protocol server component to generate the events to be consumed by the eventing framework.

Comment 1 Worker Ant 2016-08-23 10:36:44 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Atin Mukherjee 2016-08-23 11:52:23 UTC

*** This bug has been marked as a duplicate of bug 1369402 ***

Comment 3 Atin Mukherjee 2016-08-23 11:53:47 UTC
*** Bug 1369402 has been marked as a duplicate of this bug. ***

Comment 4 Worker Ant 2016-08-26 07:28:06 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 5 Worker Ant 2016-08-26 08:31:30 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 6 Worker Ant 2016-08-30 08:11:15 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#4) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 7 Worker Ant 2016-08-31 12:28:18 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#5) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 8 Worker Ant 2016-09-01 07:38:09 UTC
REVIEW: http://review.gluster.org/15294 (protocol-server: generate events) posted (#6) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 9 Worker Ant 2016-09-06 09:30:10 UTC
COMMIT: http://review.gluster.org/15294 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit db3286184a1ab89d3edb9cf4d645a2db724fada0
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Tue Aug 30 13:40:41 2016 +0530

    protocol-server: generate events
    
    This patch add/generate the events seen from/in the protocol server
    side, which will be consumed by the new eventing framework.
    
    -------------------------------------------------------------------------
    |          event                |            description                |
    |-------------------------------|---------------------------------------|
    | EVENT_CLIENT_CONNECT          |          new client connected         |
    |-------------------------------|---------------------------------------|
    | EVENT_CLIENT_AUTH_REJECT      |     client cannot be authenticated    |
    |-------------------------------|---------------------------------------|
    | EVENT_CLIENT_DISCONNECT       |        client had disconnected        |
    -------------------------------------------------------------------------
    
    Thanks to "Raghavendra Talur" <rtalur@redhat.com> for all the help
    
    Change-Id: I4fda83fae7747507f64d81a7645cc3a8a2fbaeae
    BUG: 1369403
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/15294
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 10 Shyamsundar 2017-03-06 17:22:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.