Bug 1369414 - ipa server-del fails with Python stack trace
Summary: ipa server-del fails with Python stack trace
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-23 11:08 UTC by Abhijeet Kasurde
Modified: 2016-11-04 06:02 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:02:03 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-08-23 11:08:40 UTC
Description of problem:
ipa server-del fails when user does not provide server name in interactive mode 

[root@vm-idm-027 ~]# ipa server-del 
Server name: 
ipa: ERROR: KeyError: 'cn'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1351, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1109, in run
    kw = self.process_keyword_arguments(cmd, kw)
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1096, in process_keyword_arguments
    callback(cmd, kw)
  File "/usr/lib/python2.7/site-packages/ipaclient/plugins/server.py", line 17, in interactive_prompt_callback
    "please wait...") % {'servers': ', '.join(kw['cn'])})
KeyError: 'cn'
ipa: ERROR: an internal error has occurred



Version-Release number of selected component (if applicable):
ipa-server-4.4.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ipa server-del # in interactive mode press enter after Server Name:

Actual results:
Stack trace produced by command

Expected results:
Command should notify user about blank server name

Comment 2 Martin Babinsky 2016-08-23 11:58:27 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6248

Comment 3 Martin Bašti 2016-08-24 13:51:58 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/95a594af4c99255ea4da27e609cf41b79ca7ed91

Comment 6 Sudhir Menon 2016-09-15 15:12:59 UTC
Traceback is not seen.

[root@master pubconf]# ipa server-del
Server name: 
ipa: ERROR: 'cn' is required

Verified on RHEL73 using ipa-server-4.4.0-11.el7.x86_64

Comment 8 errata-xmlrpc 2016-11-04 06:02:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.