Bug 1369430 - Track the client that performed readdirp
Summary: Track the client that performed readdirp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1211863 1371947 1384459
TreeView+ depends on / blocked
 
Reported: 2016-08-23 12:07 UTC by Poornima G
Modified: 2017-03-27 18:22 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1371947 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:22:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-08-23 12:07:21 UTC
Description of problem:
Currently when a client does a readdirp on directory say dir1 (containing f1 file), only the fact that client accessed dir1 is stored in upcall, but it sould also store that f1 was also accessed by that client. If not this may lead to stale cache on client side, when client caches the readdirp data alone. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-08-25 04:43:57 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Worker Ant 2016-08-25 05:24:15 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Worker Ant 2016-08-25 10:41:19 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 4 Worker Ant 2016-08-25 11:30:52 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir entries) posted (#4) for review on master by Poornima G (pgurusid@redhat.com)

Comment 5 Worker Ant 2016-08-26 04:05:55 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir entries) posted (#5) for review on master by Poornima G (pgurusid@redhat.com)

Comment 6 Worker Ant 2016-08-27 06:15:53 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir entries) posted (#6) for review on master by Poornima G (pgurusid@redhat.com)

Comment 7 Worker Ant 2016-08-30 05:20:24 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir entries) posted (#7) for review on master by Poornima G (pgurusid@redhat.com)

Comment 8 Worker Ant 2016-08-30 05:20:44 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed even on readdir entries) posted (#8) for review on master by Poornima G (pgurusid@redhat.com)

Comment 9 Worker Ant 2016-08-30 11:28:39 UTC
REVIEW: http://review.gluster.org/15313 (upcall: Mark the clients as accessed on readdirp entries) posted (#9) for review on master by Poornima G (pgurusid@redhat.com)

Comment 10 Worker Ant 2016-08-31 13:44:06 UTC
COMMIT: http://review.gluster.org/15313 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 9d8bbbb8f68a0c45bfbb2e891cdbd9b9a1121259
Author: Poornima G <pgurusid@redhat.com>
Date:   Thu Aug 25 10:09:20 2016 +0530

    upcall: Mark the clients as accessed on readdirp entries
    
    Currently when a client performs a readdirp it is not stored
    in upcall, as one of the clients that have accessed the files.
    Hence, when any other client modifies the file, the client that
    had performed readdirp will not get any notifications.
    
    Fix this by adding the clients to upcall database when they
    perform readdirp.
    
    Change-Id: I7767f1e26bf1bd1f67702a6d01f8aa64526ccc46
    BUG: 1369430
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/15313
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 11 Shyamsundar 2017-03-27 18:22:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.