Bug 136944 - DHCP client should run in the background
DHCP client should run in the background
Status: CLOSED DUPLICATE of bug 120427
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-10-23 14:32 EDT by Florian Effenberger
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florian Effenberger 2004-10-23 14:32:49 EDT
From Bugzilla Helper:
User-Agent: Opera/7.60 (Windows NT 5.1; U; de)

Description of problem:
The DHCP client should run in the background. When powering on the 
system without a network cable connected it takes quite a long timeout 
value until one can logon.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Boot system without networking cable connected.

Additional info:
Comment 1 Barry K. Nathan 2004-10-25 02:32:39 EDT
What kind of network card do you have? (I wonder if the long timeout
is because the driver is failing to recognize that there is no link.)

Perhaps doing DHCP in the background could be implemented as an
option, but the option of keeping it in the foreground *must* remain.
DHCP can change the machine's hostname, and if (for instance) X
happens to start before DHCP finishes and the hostname changes, it can
wreak havoc. There may be some network daemons that also need the
network link to already be up before they start, too. (For instance,
it's desirable to have network time stuff up and running before
anybody logs in, for the sake of having accurate timestamps in system
Comment 2 Florian Effenberger 2004-10-25 12:03:48 EDT
Okay, that is a point. However, allowing the backgrounding as an
option would be nice. The docs then should contain that hostname
setting is NOT recommended via DHCP.

I have a Intel PRO/1000 Mobile Connection card.
Comment 3 Bill Nottingham 2004-10-25 15:34:47 EDT
Where do you specifically see delays?

There are checks in the initscripts; it will not run dhclient if there
is no link seen. But there could be driver bugs that imply the
presence of a link when there isn't one.
Comment 4 Florian Effenberger 2004-10-25 15:44:24 EDT
I started my ThinkPad T42p, it *HAD* a link. However, there was no
DHCP server as it was at home and so it took me about 60 seconds until
I could boot on.

Maybe an option like "Press Ctrl-C to skip DHCP search" would be an idea?
Comment 5 Bill Nottingham 2004-10-25 17:33:01 EDT

*** This bug has been marked as a duplicate of 120427 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.