Bug 136957 - full satellite-sync still not working on 3.0
full satellite-sync still not working on 3.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On: 137474
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-10-23 19:00 EDT by Max Spevack
Modified: 2007-07-31 11:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:19:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-10-23 19:00:45 EDT
I still haven't been able to get a satellite-sync to fully work
without something throwing a traceback.  This is the same error that
came up on the rhel2.1 box during a recent sync attempt.

17:49:29    Importing *relevant* package metadata: rhel-i386-as-3 (2238)
17:49:29    * WARNING: this may be a slow process.
            ________________________________________
Importing:  ######################################## - complete
18:48:02
18:48:02 Linking packages to channels
18:49:33 No handler for step source-packages
18:49:33
18:49:33 Importing channel errata
+++ sending log as an email +++
 
SYNC ERROR: unhandled exception occurred:
 
(Check logs/email for potentially more detail)


Here is the contents of the email:

SYNC ERROR: unhandled exception occurred:

Exception reported from rhnblade4.rhndev.redhat.com
Time: Fri Oct 22 18:49:41 2004
Exception type exceptions.AssertionError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 128, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 153, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 254, in
_step_errata
    self.syncer.import_errata()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1605, in
import_errata
    assert erratum is not None
AssertionError

See also: 136749, from the previous sync attempt
Comment 1 Mihai Ibanescu 2004-10-28 14:29:14 EDT
This should be fixed partially by removing the channel caches on the
server side. The real fix will be addressed with triggers, see bug #137474
Comment 2 Todd Warner 2004-10-28 15:08:18 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete)
Comment 3 Todd Warner 2004-10-28 15:54:40 EDT
ON_DEV/QA_READY --> ON_QA (webQA and RHN Sat ISO/package push complete) REALLY!
Comment 4 Max Spevack 2004-11-06 02:14:42 EST
Fixed -- sat-sync works against -39
Comment 5 Todd Warner 2005-03-22 13:19:20 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.