Bug 1369577 - when calling rct cat-manifest --no-content, substitute an empty line in place of the Content Sets:
Summary: when calling rct cat-manifest --no-content, substitute an empty line in place...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-23 20:11 UTC by John Sefler
Modified: 2017-08-01 19:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1502 None None None 2016-10-04 17:56:30 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2016-08-23 20:11:23 UTC
Description of problem:
For the benefit of automated testing/parsing of output from rct cat-manifest --no-content (newly added by RFE Bug 1336883), please include an empty line in the output as a replacement for the Content Set to keep Subscription groups separated by an empty line.


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q --whatprovides `which rct`
subscription-manager-1.17.10-1.el7.x86_64


How reproducible:


Steps to Reproduce:
Given a manifest that provides at least two subscriptions...

Here is what the current format looks like when specifying --no-content option...

[root@jsefler-rhel7 ~]# rct cat-manifest --no-content  /tmp/sm-testManifestsDir/auto-services.usersys.redhat.com/test-manifests/manifest_RH00005_MCT0370.zip

+-------------------------------------------+
	Manifest
+-------------------------------------------+

General:
	Server: access.stage.redhat.com/management/distributors/
	Server Version: 0.8.16-1
	Date Created: 2013-08-09T22:34:31.381+0000
	Creator: gss-test-2a

Consumer:
	Name: jseflerSAM
	UUID: 63e3427a-4868-4310-a237-569547d74073
	Type: sam

Subscription:
	Name: Red Hat Network Satellite
	Quantity: 1
	Created: 2013-08-09T22:33:55.000+0000
	Start Date: 2013-07-12T04:00:00.000+0000
	End Date: 2014-07-12T03:59:59.000+0000
	Service Level: Premium
	Service Type: L1-L3
	Architectures: 
	SKU: MCT0370
	Contract: 10023571
	Order: 
	Account: 5226328
	Virt Limit: 4
	Requires Virt-who: True
	Entitlement File: export/entitlements/8a99f9844011489701406536f4c832f0.json
	Certificate File: export/entitlement_certificates/8959782455210639101.pem
	Certificate Version: 1.0
	Provided Products:
Subscription:
	Name: Red Hat Enterprise Linux Server, Self-support
	Quantity: 2
	Created: 2013-08-09T22:33:56.000+0000
	Start Date: 2013-07-12T04:00:00.000+0000
	End Date: 2014-07-12T03:59:59.000+0000
	Service Level: Self-support
	Service Type: L1-L3
	Architectures: x86,x86_64,ia64,s390x,ppc,s390,ppc64
	SKU: RH00005
	Contract: 10023567
	Order: 
	Account: 5226328
	Virt Limit: 
	Requires Virt-who: False
	Entitlement File: export/entitlements/8a99f9844011489701406536f89632f2.json
	Certificate File: export/entitlement_certificates/453192641648298085.pem
	Certificate Version: 1.0
	Provided Products:
		69: Red Hat Enterprise Linux Server
		180: Red Hat Beta
[root@jsefler-rhel7 ~]# 



Actual results:
 above

Expected results:
 Please add extra new line in place of the excluded "Content Sets:" so that the output would like like this....

[root@jsefler-rhel7 ~]# rct cat-manifest --no-content  /tmp/sm-testManifestsDir/auto-services.usersys.redhat.com/test-manifests/manifest_RH00005_MCT0370.zip

+-------------------------------------------+
	Manifest
+-------------------------------------------+

General:
	Server: access.stage.redhat.com/management/distributors/
	Server Version: 0.8.16-1
	Date Created: 2013-08-09T22:34:31.381+0000
	Creator: gss-test-2a

Consumer:
	Name: jseflerSAM
	UUID: 63e3427a-4868-4310-a237-569547d74073
	Type: sam

Subscription:
	Name: Red Hat Network Satellite
	Quantity: 1
	Created: 2013-08-09T22:33:55.000+0000
	Start Date: 2013-07-12T04:00:00.000+0000
	End Date: 2014-07-12T03:59:59.000+0000
	Service Level: Premium
	Service Type: L1-L3
	Architectures: 
	SKU: MCT0370
	Contract: 10023571
	Order: 
	Account: 5226328
	Virt Limit: 4
	Requires Virt-who: True
	Entitlement File: export/entitlements/8a99f9844011489701406536f4c832f0.json
	Certificate File: export/entitlement_certificates/8959782455210639101.pem
	Certificate Version: 1.0
	Provided Products:
                                                 <======== NEW LINE HERE
Subscription:
	Name: Red Hat Enterprise Linux Server, Self-support
	Quantity: 2
	Created: 2013-08-09T22:33:56.000+0000
	Start Date: 2013-07-12T04:00:00.000+0000
	End Date: 2014-07-12T03:59:59.000+0000
	Service Level: Self-support
	Service Type: L1-L3
	Architectures: x86,x86_64,ia64,s390x,ppc,s390,ppc64
	SKU: RH00005
	Contract: 10023567
	Order: 
	Account: 5226328
	Virt Limit: 
	Requires Virt-who: False
	Entitlement File: export/entitlements/8a99f9844011489701406536f89632f2.json
	Certificate File: export/entitlement_certificates/453192641648298085.pem
	Certificate Version: 1.0
	Provided Products:
		69: Red Hat Enterprise Linux Server
		180: Red Hat Beta
                                                 <======== NEW LINE HERE
[root@jsefler-rhel7 ~]#

Comment 3 John Sefler 2016-09-09 19:18:14 UTC
Not a blocker

Comment 4 Chris Snyder 2016-10-07 19:05:00 UTC
Moving to MODIFIED as the upstream PR has been merged and should be included in the first build of subscription-manager for RHEL 7.4

Comment 6 Rehana 2017-04-11 14:42:16 UTC
Retested with :

#  rpm -q --whatprovides `which rct`
subscription-manager-1.19.5-1.el7.x86_64

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.5-1.el7
python-rhsm: 1.19.3-1.el7


Observed that now a new line is added in the place of the excluded content sets:

# rct cat-manifest --no-content manifestRH00001andMCT2363.zip 

+-------------------------------------------+
	Manifest
+-------------------------------------------+

General:
	Server: 
	Server Version: 0.9.51.20-1
	Date Created: 2017-02-14T16:33:51.832+0000
	Creator: candlepin_admin

Consumer:
	Name: RH00001andMCT2363
	UUID: 26bb024a-c79b-4797-8592-ea96f4808cb2
	Type: sam

Subscription:
	Name: Red Hat Enterprise Linux for Virtual Datacenters, Premium
	Quantity: 4
	Created: 2017-02-14T16:33:25.000+0000
	Start Date: 2017-02-13T05:00:00.000+0000
	End Date: 2018-02-13T04:59:59.000+0000
	Service Level: Premium
	Service Type: L1-L3
	Architectures: 
	SKU: RH00001
	Contract: 
	Order: 
	Account: 
	Virt Limit: unlimited
	Requires Virt-who: True
	Entitlement File: export/entitlements/8a99f9815a2493be015a3d78b50e5617.json
	Certificate File: export/entitlement_certificates/5995022501232533635.pem
	Certificate Version: 3.2
	Provided Products:
	Derived Products:
		69: Red Hat Enterprise Linux Server
		70: Red Hat Enterprise Linux Server - Extended Update Support
		84: Red Hat Enterprise Linux High Availability (for RHEL Server) - Extended Update Support
		86: Red Hat Enterprise Linux Load Balancer (for RHEL Server) - Extended Update Support
		91: Red Hat Enterprise Linux Resilient Storage (for RHEL Server) - Extended Update Support
		93: Red Hat Enterprise Linux Scalable File System (for RHEL Server) - Extended Update Support
		127: Red Hat S-JIS Support (for RHEL Server) - Extended Update Support
		133: Red Hat Enterprise Linux High Performance Networking (for RHEL Server) - Extended Update Support
		176: Red Hat Developer Toolset (for RHEL Server)
		180: Red Hat Beta
		182: Red Hat EUCJP Support (for RHEL Server) - Extended Update Support
		201: Red Hat Software Collections (for RHEL Server)
		205: Red Hat Software Collections Beta (for RHEL Server)
		240: Oracle Java (for RHEL Server)
		244: Oracle Java (for RHEL Workstation)
		271: Red Hat Enterprise Linux Atomic Host
		272: Red Hat Enterprise Linux Atomic Host Beta
		317: dotNET on RHEL (for RHEL Server)
                                           --> new line is added here 
Subscription:
	Name: RHEL Server, Premium (1-2 sockets) (Up to 1 guest) (Inc RHEL 3 & RHEL 4 support)
	Quantity: 2
	Created: 2017-02-14T16:33:23.000+0000
	Start Date: 2017-02-13T05:00:00.000+0000
	End Date: 2018-02-13T04:59:59.000+0000
	Service Level: Premium
	Service Type: L1-L3
	Architectures: x86_64,ppc64le,ppc64,ia64,ppc,s390,x86,s390x
	SKU: MCT2363
	Contract: 11258061
	Order: 
	Account: 5755088
	Virt Limit: 1
	Requires Virt-who: True
	Entitlement File: export/entitlements/8a99f98a5a386f8b015a3d78aff82d45.json
	Certificate File: export/entitlement_certificates/2319253232566041770.pem
	Certificate Version: 3.2
	Provided Products:
		69: Red Hat Enterprise Linux Server
		180: Red Hat Beta
		240: Oracle Java (for RHEL Server)
	Derived Products:



Marking as Verified.

Comment 7 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.