Bug 136959 - netpbm - manpages in a wrong format
netpbm - manpages in a wrong format
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 19:36 EDT by Michal Jaegermann
Modified: 2013-07-02 19:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: 10.25-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 09:48:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar.gz archive with nroff format manpages for the current netpbm (280.20 KB, application/octet-stream)
2004-10-24 18:24 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2004-10-23 19:36:58 EDT
Description of problem:

It looks like that "manpages" for netpbm-progs are already
in a "preformatted text form".

      file -z $( rpm -qd netpbm-progs )

prints "ASCII English text" for nearly all of these. 'man'
is later doing a fine mess on a display from that.  Results
of things like 'man -t jpegtopnm' are also not that exciting.

Version-Release number of selected component (if applicable):
netpbm-10.25-2
Comment 1 Jindrich Novy 2004-10-24 07:59:07 EDT
Yes, this is known issue as the upstream version of man pages is
available only in HTML form. For explanation see the snippet from
http://netpbm.sourceforge.net/ :

----- snip
The source code packages do not contain documentation. The
documentation is online, and if you want a local copy, you download it
from that webserver. Instructions for doing that download, and
installing the documentation on your system, are in the source code
package in the doc/USERDOC file.

note: If you're wondering why the documentation isn't simply included
in the source tarballs: It's because the Netpbm maintainer is lazy and
doesn't want to make multiple copies of things. 
----- snip

I see no positive solution to that because the upstream maintainer
decided to have all man pages in pure ASCII format. I think that
downgrade to old pages doesn't make sense because their content is
significantly different from ordinary man pages present in netpbm-9.24.

From a maintainer's point of view it's good to have all the doc stuff
in one place. OTOH the only solution for that is to use texinfo to
keep documentation in one place and let other formats like man pages,
HTML, etc. be generated correctly from it. (I mean man pages with
links to other netpbm programs, etc.) Maybe it is a good thing to
suggest to Bryan, the netpbm upstream maintainer.

Unfortunately I have to keep our version of netpbm in sync with
upstream so I'll contact Bryan about this and I close this as WONTFIX now.

cheers,
Jindrich
Comment 2 Michal Jaegermann 2004-10-24 11:55:58 EDT
In doc/USERDOC from netpbm sources one can also find this
----- snip
  1) convert the HTML to troff with the 'makeman' program in the
     'buildtools' directory of the Netpbm source tree.  This is a 
     Python program.
----- snip

and later on

----- snip
Here is an example of making troff pages:

  mkdir netpbmdoc
  cd netpbmdoc
  wget --recursive --relative http://netpbm.sourceforge.net/doc/
  cd netpbm.sourceforge.net/doc
  PATH="/usr/src/netpbm/buildtools/:$PATH"
  make -f /usr/src/netpbm/buildtools/Makefile.manpage manpages
  make -f /usr/src/netpbm/buildtools/Makefile.manpage installman
  cd ../../..
  rm -r netpbmdoc

  man ppmtogif
----- snip

"cat" pages are made in a slightly different way shown in another
example.  I have to admit that I did not try that so far.  Are you
saying that this is incorrect?
Comment 3 Michal Jaegermann 2004-10-24 18:24:30 EDT
Created attachment 105709 [details]
tar.gz archive with nroff format manpages for the current netpbm

Out of a sheer curiosity I followed steps outlined in USERDOC file, as quoted
in the previous comment and with obvious modifications, and in a short time
I ended up with 310 manpages in troff format.  Archived results are attached.
They display like they should and 'man -t' also does not have problems.
Comment 4 Jindrich Novy 2004-10-25 05:09:59 EDT
Argh, I missed that part in USERDOC. Thanks for the man pages. I'll
build netpbm with new man pages today.
Comment 5 Jindrich Novy 2004-10-25 09:48:31 EDT
The new man pages are now included in netpbm-10.25-3.

Thanks!
Comment 6 Michal Jaegermann 2004-10-25 12:48:23 EDT
Thanks!  Just for the record and in an interest of clarity.  This
is really a script, executed in 'doc' subdiretcory of a build tree,
which I used to produce these pages:

#!/bin/bash
BT=$( dirname ${PWD})"/buildtools"
mkdir netpbmdoc
cd netpbmdoc
wget --recursive --relative http://netpbm.sourceforge.net/doc/
cd netpbm.sourceforge.net/doc
cp -al ${BT}/makeman .
make -f ${BT}/Makefile.manpage manpages
mkdir -p ../troffdoc/man1 && mv *.1 ../troffdoc/man1
mkdir -p ../troffdoc/man3 && mv *.3 ../troffdoc/man3
mkdir -p ../troffdoc/man5 && mv *.5 ../troffdoc/man5

The one from USERDOC likely assumes some older version of
makefiles or something of that sort. 'wget' every time is
clearly not required. :-)

Note You need to log in before you can comment on or make changes to this bug.