Bug 1369727 - upgrade failed at pluginOrderOverride checking task in post.yaml
Summary: upgrade failed at pluginOrderOverride checking task in post.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-24 08:49 UTC by Anping Li
Modified: 2016-09-27 09:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:45:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Anping Li 2016-08-24 08:49:52 UTC
Description of problem:

upgrade failed at the task 'Check for warnings to be printed at the end of the upgrade' in post.yml

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.3.14

How reproducible:
always

Steps to Reproduce:
1. install atomic-openshift-3.2
2. upgrade to 3.3
   ansible-playbook /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_3/upgrade.yml
3. check pluginOrderOverride 
[root@host4master ~]# grep pluginOrderOverride /etc/origin/master/master-config.yaml |wc
      0       0       0


Actual results:
TASK [command] *****************************************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades/post.yml:65
fatal: [host4master.example.com]: FAILED! => {"changed": true, "cmd": ["grep", "pluginOrderOverride", "/etc/origin/master/master-config.yaml"], "delta": "0:00:00.003026", "end": "2016-08-24 04:20:15.546374", "failed": true, "rc": 1, "start": "2016-08-24 04:20:15.543348", "stderr": "", "stdout": "", "stdout_lines": [], "warnings": []}

NO MORE HOSTS LEFT *************************************************************
    to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_3/upgrade.retry

PLAY RECAP *********************************************************************
host4master.example.com    : ok=277  changed=28   unreachable=0    failed=1   
host4node.example.com      : ok=96   changed=5    unreachable=0    failed=0   


Expected results:


Additional info:

Comment 1 Devan Goodwin 2016-08-24 13:04:20 UTC
My apologies, I completely forgot to test the normal no-config-upgrade required case after implementing the change.

Fixed in https://github.com/openshift/openshift-ansible/pull/2351

Comment 3 Anping Li 2016-08-25 04:56:39 UTC
Verified and pass on atomic-openshift-utils-3.3.15-1

Comment 5 errata-xmlrpc 2016-09-27 09:45:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.