Bug 136977 - xeyes missing from xorg-x11 packages
Summary: xeyes missing from xorg-x11 packages
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-24 17:06 UTC by james
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-12 17:04:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description james 2004-10-24 17:06:00 UTC
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; Linux i686; U)  [en]

Description of problem:
xeyes missing from xorg-x11 packages

Version-Release number of selected component (if applicable):
xorg-x11-tools-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

xeyes is pretty useful for doing a quick test of an X server 
connection on a remote host, so "missing" is a problem.

Comment 1 Barry K. Nathan 2004-10-25 03:27:43 UTC
You could run xclock or xlogo instead of xeyes.

It looks like this is intentional. Quoting from the xorg-x11 RPM
changelog:
---begin quote---
* Sun Aug 22 2004 Mike A. Harris <mharris@redhat.com> 6.7.99.902-6

- Remove a bunch of legacy Xaw/Xt applications which really should not be
  part of X11 sources (xbiff,xditview,xeyes,xmessage)
---end quote---


Comment 2 Kristian Høgsberg 2004-12-12 17:04:23 UTC
Yes, this is an intentional omission -  we're trying to cut down on
the number of legacy X applications we ship.  As mentioned in comment
1, there are other options for testing connection.  I would recommend
using xev, which we probably will ship as long as we ship the X window
system.

Comment 3 james 2004-12-16 20:35:10 UTC
> we're trying to cut down on the number of legacy X applications we ship

From my point of view, you're not doing anybody any favors. 
Furthermore, you provide an Xorg distribution which is incomplete.

The polite way to do this would be to push all these selected
components into a kind of "Xorg Extras" package, to allow the user to
decide whether or not to install.  As I understand, Xorg is interested
in further modularizing the X11 distribution, so defining an "Xorg
Extras" package could be of benefit to everyone.

Comment 4 Eric Hopper 2005-03-12 04:14:32 UTC
I agree with the previous commenter.  xeyes is one of my favorite Xorg apps
actually, and I would very much like a way to install it even if it wasn't
included by default.


Comment 5 Ra P. 2005-05-23 10:10:51 UTC
If the cursor blends into the desktop (as when an old monitor is pressed into
service), it is sometimes quicker to pull up xeyes and track its approximate
location than to change window managers or fiddle with color settings.

bkm

Comment 6 Roumen Semov 2005-08-22 22:14:30 UTC
I want my xeyes back into an rpm!!! I am tired of looking for it. It needs to be
as a part of some package in the official Fedora distro. Why are we doing such a
drastic change by removing an old application like xeyes? One big reason I like
Linux/unix is that stuff that existed 20 years ago still exists (and works),
let's keep it this way.
Roumen Semov

Comment 7 Bob Jenkins 2005-09-20 04:56:33 UTC
I agree. xeyes is a great quick way to gauge the responsiveness of an X session,
which you can't do with xlogo or xclock. What earthly reason is there to drop
it? It's not as if it's very large (~12k binary) and I can't imagine that
maintenance is much of a chore.


Note You need to log in before you can comment on or make changes to this bug.