Bug 1369786 - Autopart fails on installation from live usb created by l-i-t-d
Summary: Autopart fails on installation from live usb created by l-i-t-d
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1369607 (view as bug list)
Depends On:
Blocks: F25BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-08-24 11:57 UTC by Petr Schindler
Modified: 2016-10-24 15:31 UTC (History)
10 users (show)

Fixed In Version: anaconda-25.20.4-1 anaconda-25.20.4-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-07 03:34:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anaconda.log (18.46 KB, text/plain)
2016-08-24 12:02 UTC, Petr Schindler
no flags Details
program.log (104.83 KB, text/plain)
2016-08-24 12:02 UTC, Petr Schindler
no flags Details
storage.log (9.47 KB, text/plain)
2016-08-24 12:03 UTC, Petr Schindler
no flags Details
Screenshot of error message (106.96 KB, image/png)
2016-08-24 12:03 UTC, Petr Schindler
no flags Details
output of 'mount -a' (2.85 KB, text/plain)
2016-08-24 12:05 UTC, Petr Schindler
no flags Details
storage.log cmurphy (504.25 KB, text/plain)
2016-09-14 01:47 UTC, Chris Murphy
no flags Details
anaconda.log cmurphy (218.66 KB, text/plain)
2016-09-14 01:48 UTC, Chris Murphy
no flags Details
journal.log cmurphy (1.35 MB, text/x-vhdl)
2016-09-14 01:48 UTC, Chris Murphy
no flags Details
program.log cmurphy (188.76 KB, text/plain)
2016-09-14 01:49 UTC, Chris Murphy
no flags Details

Description Petr Schindler 2016-08-24 11:57:43 UTC
Description of problem:
I put Alpha 1-1 image to usb with:
livecd-iso-to-disk --reset-mbr --format Fedora-Workstation-Live-x86_64-25_Alpha-1.1.iso /dev/sdb

In installation destination I choose one disk and choose to delete all the partitions. Then error appears with message:
"autopart failed:
/dev/sdd1 is currently mounted and cannot be used for the installation. Please unmount it and retry."

/dev/sdd is the media from which I booted the system so it cannot be unmounted.

This exact thing happens with two different flash disks and on two different computers.

Version-Release number of selected component (if applicable):
anaconda-24.20-2.fc25.x86_64
Fedora-Workstation-Live-x86_64-25_Alpha-1.1.iso

How reproducible:
always

Steps to Reproduce:
1. create bootable flash disk by running livecd-iso-to-disk --reset-mbr --format Fedora-Workstation-Live-x86_64-25_Alpha-1.1.iso /dev/<flash disk>
2. Boot, go to the installation destination
3. Choose disk and let anaconda to autopart

Actual results:
Autopart fails and wants you to unmount usb from which the installation runs.

Expected results:
Chosen disk is used and parted

Additional info:
I propose this as beta blocker as it violates the combination of beta criterion: 
"All release-blocking images must boot in their supported configurations. This criterion differs from the similar Alpha criterion only in that it requires all supported methods of writing a Fedora USB stick to work, not just any single one."
and the alpha criterion:
"The installer must be able to complete an installation to a single disk using automatic partitioning."
Installation works with other methods of writing an image to usb stick.

Comment 1 Petr Schindler 2016-08-24 12:02:18 UTC
Created attachment 1193606 [details]
anaconda.log

Comment 2 Petr Schindler 2016-08-24 12:02:42 UTC
Created attachment 1193607 [details]
program.log

Comment 3 Petr Schindler 2016-08-24 12:03:08 UTC
Created attachment 1193608 [details]
storage.log

Comment 4 Petr Schindler 2016-08-24 12:03:42 UTC
Created attachment 1193609 [details]
Screenshot of error message

Comment 5 Petr Schindler 2016-08-24 12:05:17 UTC
Created attachment 1193610 [details]
output of 'mount -a'

Comment 6 Adam Williamson 2016-08-24 21:47:25 UTC
+1 beta blocker, also +1 Alpha FE if we wind up slipping and someone wants to fix this this week...

Comment 7 Geoffrey Marr 2016-08-29 19:39:53 UTC
Discussed during the 2016-08-29 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it is a clear violation of the Beta Blocker Criteria, which states "All release-blocking images must boot in their supported configurations. This criterion differs from the similar Alpha criterion only in that it requires all supported methods of writing a Fedora USB stick to work, not just any single one" and "The installer must be able to complete an installation to a single disk using automatic partitioning."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-29/f25-blocker-review.2016-08-29-16.00.txt

Comment 8 Geoffrey Marr 2016-08-31 00:36:37 UTC
I am seeing this same bug on Fedora-Workstation-Live-x86_64-25_Alpha-2.iso.

Comment 9 Chris Murphy 2016-09-14 01:46:16 UTC
I can reproduce this. However in the attached logs I see this

01:44:59,594 INFO anaconda: Performing post-installation setup tasks -- DONE
01:44:59,594 INFO anaconda: Thread Done: AnaInstallThread (139661271574272)

So the installation completed? That doesn't make sense based on the screen shot and description of it failing within autopart. And I also don't see sda, sdb, sdc, or sdd1 in any of the logs, but foudn in the screenshot. So I'm going to attach a bunch of my own logs that show sdb1 (USB stick) as failing the installation for the same reason; and the storage.log also contains a blivet exception and traceback.

Comment 10 Chris Murphy 2016-09-14 01:47:36 UTC
Created attachment 1200675 [details]
storage.log cmurphy

Comment 11 Chris Murphy 2016-09-14 01:48:08 UTC
Created attachment 1200676 [details]
anaconda.log cmurphy

Comment 12 Chris Murphy 2016-09-14 01:48:55 UTC
Created attachment 1200677 [details]
journal.log cmurphy

Comment 13 Chris Murphy 2016-09-14 01:49:29 UTC
Created attachment 1200678 [details]
program.log cmurphy

Comment 14 Chris Murphy 2016-09-14 02:10:32 UTC
21:35:22,726 INFO blivet: sdb1 looks to be the live device; marking as protected
...
21:35:26,297 INFO program: Running... umount /home
21:35:26,300 INFO program: stderr:
21:35:26,300 INFO program: b'umount: /home: target is busy'
...
21:35:26,416 INFO blivet: teardown of EncHome failed: umount of /home failed (32)
##/home is encrypted on the live media using --home-size-mb option when creating
...
19:36:02,346 DEBUG blivet: removing all non-preexisting partitions ['req0(id 367)', 'req1(id 374)', 'req2(id 381)', 'sdb1(id 11)'] from disk(s) ['sda'
....

OK so decent chance comment 9 through comment 13 can be ignored because I used --overlay-size-mb and --home-size-mb and end up with cluttered logs as a result. I get the same failure but possibly for different reasons.

Comment 15 Chris Murphy 2016-09-14 02:57:53 UTC
I just retested without --home-size-mb and --overlay-size-mb and get the same results in the logs I attached, minus the complaints about /home.

Comment 16 Geoffrey Marr 2016-09-15 21:27:32 UTC
*** Bug 1369607 has been marked as a duplicate of this bug. ***

Comment 17 Geoffrey Marr 2016-09-26 16:34:20 UTC
Hey Anaconda Devs,

After reviewing this bug during the 2016-09-26 Blocker-Review-Meeting, we noticed that there has been no progress made in several days. Is there anything the QA team can do to help get this bug solved?

Thanks,
Geoff M. - QA
IRC: coremodule

Comment 18 Chris Murphy 2016-09-26 18:15:06 UTC
Retested with Fedora-Workstation-Live-x86_64-25-20160924.n.0.iso which contains anaconda 25.20.1-1. Used livecd-tools-23.4-1.fc24.x86_64.
Same results in the logs as what are attached (by me), including all the blivet exception tracebacks.

Comment 19 Radek Vykydal 2016-09-30 11:05:01 UTC
https://github.com/rhinstaller/anaconda/pull/817

Comment 20 Fedora Update System 2016-10-05 20:29:18 UTC
anaconda-25.20.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-067d26633e

Comment 21 Kamil Páral 2016-10-06 17:15:57 UTC
This worked for me with Beta 1.1.

Comment 22 Fedora Update System 2016-10-07 03:34:56 UTC
anaconda-25.20.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.