Bug 1369798 - OSP-9/10 upgrades fails when using cinder-block-storage.
Summary: OSP-9/10 upgrades fails when using cinder-block-storage.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-08-24 12:31 UTC by Sofer Athlan-Guyot
Modified: 2016-12-29 16:54 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:53:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 359844 None None None 2016-08-24 12:33:22 UTC
Launchpad 1616453 None None None 2016-08-24 12:31:32 UTC

Description Sofer Athlan-Guyot 2016-08-24 12:31:33 UTC
Description of problem:  See the upstream bug.

Comment 2 Sofer Athlan-Guyot 2016-08-24 12:33:23 UTC
Adding upstream bug fix review

Comment 3 Mike Burns 2016-08-26 18:45:44 UTC
(In reply to Sofer Athlan-Guyot from comment #0)
> Description of problem:  See the upstream bug.

Please include the bug description so people tracking bugzilla can see what the issue is and QE can determine how to test.

Comment 4 Sofer Athlan-Guyot 2016-08-29 21:00:21 UTC
Using

    openstack overcloud deploy --templates --libvirt-type qemu \
          --control-flavor baremetal \
          --compute-flavor baremetal \
          --block-storage-flavor baremetal \
          --ceph-storage-flavor baremetal \
          --swift-storage-flavor baremetal \
          --control-scale 3 \
          --compute-scale 1 \
          --block-storage-scale 1 \
          --swift-storage-scale 1 \
          --ceph-storage-scale 1 \
          --neutron-network-type vxlan --neutron-tunnel-types vxlan \
          --ntp-server pool.ntp.org \
          --timeout 90 \
          -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
          -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml \
          -e $HOME/network-environment.yaml \
          -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
          -e /usr/share/openstack-tripleo-heat-templates/environments/config-debug.yaml \
          -e /home/stack/deploy_env.yaml

Fails very early with:

    12:41:18 2 nodes with profile None won't be used for deployment now
    12:41:18 Configuration has 1 warnings, fix them before proceeding.
    12:41:25 ERROR: Failed to validate: Failed to validate: resources[0]: The Parameter (Flavor) was not provided.

No other relevant message was included in the log.

Doing a pdb session on

    /usr/lib/python2.7/site-packages/heat/engine/stack.py +807

I could see the failing template:

    (Pdb) p res.template_name
    u'file:///usr/share/openstack-tripleo-heat-templates/puppet/cinder-storage.yaml'

Comment 6 Omri Hochman 2016-11-07 21:51:36 UTC
unable to reproduce: openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 15:53:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.