Bug 1369827 - Organize hosted engine UI deployment
Summary: Organize hosted engine UI deployment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Phillip Bailey
QA Contact: Nikolai Sednev
URL:
Whiteboard: PM-01
: 1361894 1384462 (view as bug list)
Depends On: 1392957
Blocks: 1331498 1361894
TreeView+ depends on / blocked
 
Reported: 2016-08-24 13:48 UTC by Roy Golan
Modified: 2017-05-11 09:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The engine was unaware of the availability of hosted engine agents on a given host. Consequence: Undeploy and Deploy options available when they should not be. Fix: VDSM now reports availability of HE agents for each host. Result: Only the relevant option appears.
Clone Of:
Environment:
Last Closed: 2017-04-21 09:52:32 UTC
oVirt Team: SLA
ylavi: ovirt-4.1+
ylavi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
undeploy is removed for new hosts.png (70.77 KB, image/png)
2016-12-28 13:48 UTC, Nikolai Sednev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1383156 0 high CLOSED Enable HE deploy option in 3.6 cluster compatibility and add note in hosted engine tab that it will only work in host th... 2021-02-22 00:41:40 UTC
oVirt gerrit 66605 0 master ABANDONED core: Add hostedEngineComponentsInstalled to vds_dynamic 2016-12-02 13:46:25 UTC
oVirt gerrit 66773 0 master MERGED webadmin: Improve HE Management in Host Dialogs 2016-12-14 20:57:59 UTC
oVirt gerrit 67483 0 master ABANDONED core: Add ha_running to vds_statistics 2016-12-02 13:46:46 UTC
oVirt gerrit 68119 0 master ABANDONED core: Add running services to vds_dynamic 2017-03-28 12:00:42 UTC
oVirt gerrit 68120 0 master MERGED core: Add hosted engine deployed to vds_dynamic 2016-12-14 16:53:44 UTC

Internal Links: 1383156

Description Roy Golan 2016-08-24 13:48:05 UTC
Description of problem:
'Undeploy ' option under Add Host dialog will not be supported and should be removed

Version-Release number of selected component (if applicable):
all

How reproducible:
100%

Steps to Reproduce:
1. Click Add Host -> click 'Hosted Engine' side tab

Actual results:
'Undeploy' action is available

Expected results:
'Undpeloy' should not be available

Additional info:

Comment 1 Doron Fediuck 2016-08-24 14:13:06 UTC
Just to clarify;
this is also about allowing to handle an existing host.
So the hosted engine side-tab should be in the edit host dialog as well.

It should allow to make a standard host an HE node /if hosted engine is already installed/.

It should also allow to undeploy an HE node so it becomes a standard hypervisor. This will be allowed only if it's not the last host in the system. Otherwise the option will be disabled with a tool tip to explain why.

And yes, the undeploy option in the new host dialog should be removed.

Comment 2 Doron Fediuck 2016-10-25 06:54:27 UTC
*** Bug 1384462 has been marked as a duplicate of this bug. ***

Comment 3 Doron Fediuck 2016-12-11 11:27:27 UTC
*** Bug 1361894 has been marked as a duplicate of this bug. ***

Comment 4 Yaniv Lavi 2016-12-14 16:23:21 UTC
This bug had requires_doc_text flag, yet no documentation text was provided. Please add the documentation text and only then set this flag.

Comment 5 Yaniv Lavi 2016-12-28 10:30:41 UTC
Moving to POST as this needs to be backported, if possible.

Comment 6 Nikolai Sednev 2016-12-28 13:43:28 UTC
Works for me on these components on hosts:
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0-0.0.master.20161221071755.git46cacd3.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
libvirt-client-2.0.0-10.el7_3.2.x86_64
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
ovirt-hosted-engine-ha-2.1.0-0.0.master.20161221070856.20161221070854.git387fa53.el7.centos.noarch
rhevm-appliance-20161116.0-1.el7ev.noarch
sanlock-3.4.0-1.el7.x86_64
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
vdsm-4.18.999-1218.gitd36143e.el7.centos.x86_64
ovirt-imageio-daemon-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Nov 16 13:15:13 EST 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Wed Nov 16 13:15:13 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)

I've tested on upstream, please consider moving to verified.

On engine:
ovirt-engine-setup-plugin-ovirt-engine-common-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-proxy-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-iso-uploader-4.1.0-0.0.master.20160909154152.git14502bd.el7.centos.noarch
ovirt-engine-userportal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dbscripts-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
python-ovirt-engine-sdk4-4.1.0-0.1.a0.20161215git77fce51.el7.centos.x86_64
ovirt-host-deploy-java-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.2-1.el7.noarch
ovirt-engine-dwh-setup-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-imageio-proxy-setup-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-engine-tools-backup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-backend-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-tools-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-webadmin-portal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-restapi-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-engine-cli-3.6.9.2-1.el7.centos.noarch
ovirt-web-ui-0.1.1-2.el7.centos.x86_64
ovirt-engine-setup-base-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7.centos.noarch
ovirt-engine-dwh-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-hosts-ansible-inventory-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-0.4.20161128git5ed6f96.el7.centos.noarch
ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-guest-agent-common-1.0.13-1.20161220085008.git165fff1.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7.centos.noarch
ovirt-engine-wildfly-10.1.0-1.el7.x86_64
ovirt-engine-lib-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Tue Dec 6 23:06:41 UTC 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.3.1611 (Core)

Comment 7 Nikolai Sednev 2016-12-28 13:48:02 UTC
Created attachment 1235638 [details]
undeploy is removed for new hosts.png

Comment 8 Phillip Bailey 2017-01-03 14:58:14 UTC
(In reply to Nikolai Sednev from comment #7)
> Created attachment 1235638 [details]
> undeploy is removed for new hosts.png

Nikolai, the Undeploy option for new hosts was removed intentionally. Please see Comment 1.

Comment 9 Phillip Bailey 2017-01-04 14:49:12 UTC
(In reply to Yaniv Dary from comment #5)
> Moving to POST as this needs to be backported, if possible.

Yaniv, to what branch are you suggesting this be backported? In case you aren't already aware, this feature depends on a couple of VDSM patches that will need to be backported, as well.

Comment 10 Yaniv Lavi 2017-01-05 14:57:25 UTC
(In reply to Phillip Bailey from comment #9)
> (In reply to Yaniv Dary from comment #5)
> > Moving to POST as this needs to be backported, if possible.
> 
> Yaniv, to what branch are you suggesting this be backported? In case you
> aren't already aware, this feature depends on a couple of VDSM patches that
> will need to be backported, as well.

4.0. If you find this change risky please say, so we can discuss it.

Comment 11 Sandro Bonazzola 2017-01-25 07:56:41 UTC
4.0.6 has been the last oVirt 4.0 release, please re-target this bug.

Comment 12 Yaniv Lavi 2017-02-13 13:21:31 UTC
Will this be backported?

Comment 13 Nikolai Sednev 2017-03-05 20:22:40 UTC
Undeploy option was removed for "click Add Host -> click 'Hosted Engine' side tab".
Works for me on these components on hosts:
libvirt-client-2.0.0-10.el7_3.4.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.6.x86_64
rhevm-appliance-20160721.0-2.el7ev.noarch
mom-0.5.9-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0.3-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
sanlock-3.4.0-1.el7.x86_64
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
vdsm-4.19.6-1.el7ev.x86_64
ovirt-host-deploy-1.6.0-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-imageio-common-1.0.0-0.el7ev.noarch
ovirt-imageio-daemon-1.0.0-0.el7ev.noarch
ovirt-setup-lib-1.1.0-1.el7ev.noarch
ovirt-hosted-engine-ha-2.1.0.3-1.el7ev.noarch
Linux version 3.10.0-514.6.1.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Sat Dec 10 11:15:38 EST 2016
Linux 3.10.0-514.6.1.el7.x86_64 #1 SMP Sat Dec 10 11:15:38 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)

On engine:
rhev-guest-tools-iso-4.1-3.el7ev.noarch
rhevm-dependencies-4.1.0-1.el7ev.noarch
rhevm-doc-4.1.0-2.el7ev.noarch
rhevm-branding-rhev-4.1.0-1.el7ev.noarch
rhevm-setup-plugins-4.1.0-1.el7ev.noarch
rhevm-4.1.1.2-0.1.el7.noarch
Linux version 3.10.0-514.6.2.el7.x86_64 (mockbuild@x86-017.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Fri Feb 17 19:21:31 EST 2017
Linux 3.10.0-514.6.2.el7.x86_64 #1 SMP Fri Feb 17 19:21:31 EST 2017 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)


Note You need to log in before you can comment on or make changes to this bug.