Bug 136987 - loadkeys sometimes hangs when not called from VT
loadkeys sometimes hangs when not called from VT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-24 16:37 EDT by paul bateson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 15:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -o kudzu.txt /usr/sbin/kudzu (70.99 KB, text/plain)
2004-10-25 16:16 EDT, paul bateson
no flags Details

  None (edit)
Description paul bateson 2004-10-24 16:37:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
Good Day . . .

A boot-up message error from kudzu about a segmenation fault passed
too quickly - I cannot locate a log file - please direct me - just
happened - I have had this up for two days


Version-Release number of selected component (if applicable):
kudzu-1.1.68.2-1

How reproducible:
Always

Steps to Reproduce:
1. power down - power up
2.
3.
    

Actual Results:  segmentation fault message

Expected Results:  clean boot

Additional info:


Strange things happening:

keyboard defaults to UK English - tried to chnage it to US English -
after reboot defaults to UK English

Synaptic cannot find RPM database - apt-get says not installed but
menu item starts app

don't know if these are related - too new to this distro
Comment 1 Bill Nottingham 2004-10-25 15:38:02 EDT
Can you post the output of 'strace /usr/sbin/kudzu' when run post-boot?
Comment 2 paul bateson 2004-10-25 16:16:02 EDT
Created attachment 105749 [details]
strace -o kudzu.txt /usr/sbin/kudzu

The keyboard errors that I am experiencing could be attributed to a UK English
keyboard. For example, the "@" symbol from SHIFT+2 in now a quotation mark and
vice versa. This is maybe how the English keyboard is supposed to be.

I do not know. I have never seen an English keyboard. Maybe someone on your
network uses the UK keyboard and can advise. Other special character keys are
reversed also.

Hope this helps.
Comment 3 Bill Nottingham 2004-10-25 16:21:43 EDT
OK, so post-boot it doesn't segfault. Hm.
Comment 4 paul bateson 2004-10-25 16:59:09 EDT
Good Day . . .

I cycled through about half a dozen power down/power up sequences and
I learned some more information.

The segmentation fault does not appear anymore.

I changed the keyboard system settings > keyboard to Swedish,
UKEnglish and USEnglish but nothing happened. Changing USEnglish
worked once but it did not survive a reboot. I am unable to change the
keyboard.

One thought, my system is set to UKEnglish possibly the UKEnglish
keyboard is the only option. Doubtful but possible.

On USEnglish keyboard this is the character from SHIFT + 3 - £££££. It
should be the number character which I have completely lost and is
nowhere on the keyboard.

I give you this information because kudzu has something to do with
hardware. This problem may have caused the 'segfault' or is a result
of it.

Hope this helps because I am unable to type anything but alpha characters!

Thank You
Comment 5 Bill Nottingham 2004-10-25 17:08:54 EDT
Assigning to kbd; kudzu doesn't really touch keymaps.
Comment 6 Eido Inoue 2004-11-08 12:53:35 EST
loadkeys, which system-config-keyboard calls, seems to get upset when
not run from a VT on FC2.

Works fine on FC3 though.
Comment 7 Miloslav Trmač 2005-04-12 15:46:28 EDT
I can't reproduce loadkeys hanging on FC2...
and I doubt fedora legacy will be fixing this. Sorry.

Note You need to log in before you can comment on or make changes to this bug.